Der OMSI 2.0 Performance Thread

The forum is in reduced operation. The Addon and Support forums remain open.
Please note that OMSI is no longer under development. Some of the developers are now working on a new simulator. Further information concerning the LOTUS-Simulator can be found here.
  • Mich verwundern diese extremen Performanceschwankungen etwas. Mich würde mal interessieren ob M&R nur auf Intel getestet hat oder auch auf AMD. Scheinbar haben nur Leute mit AMD Systemen so extreme Probleme.


    Das mit dem Nachladen stimmt. Sobald eine neue Kachel geladen wird stockt das Spiel aufs Extremste. War beim ersten Teil nicht so. Zwar war das dort auch festzustellen, allerdings nicht so heftig wie im Zweiten.


    Übrigens funktioniert der Trick mit dem CFF Explorer auch in OMSI 2. Also das man in OMSI 2 den nutzbaren RAM-Speicher auf 4GB anheben kann. Damit verbessert sich die Leistung auch etwas.

  • Also bin gestern mal ne 92 Runde mit dem Gelenkbus gefahren und das auf 2009 Einstellungen obwohl mein Dell Notebook von 2013 ist und viele andere Spiele auf hohen Einstellungen sauber laufen.
    Rund um Spandau Rathhaus ist es mehr als stockend. Das Thema mit dem Nachladen habe ich auch festgestellt. Das Spiel stockt kurz. Weiterhin auffällig ist das die Maus sehr deutliche Reaktionszeiten hat beim lenken. Zwischendurch auch immer mal wieder irgendwelche "Texturen laden" Fehlermeldungen wo das Spiel abschmiert.


    Fazit:


    Das Spiel ist aus meiner Sicht von der Spielbarkeit keinen Deut besser geworden

  • Ich habe ja nun 2 Videos bereits veröffentlicht und ich muss sagen Grundorf läuft ganz Geschmeidig und ohne Probleme aber das kann man von Berlin/Spandau nicht gerade sagen die Map ist so Ressourchen Fressend ich frage mich wie man mit dieser Hardware Minimum:
    OS: Windows XP/Vista/7/8
    Processor: 2,6 GHz
    Memory: 2 GB RAM
    Graphics: GeForce oder vergleichbare ATI mit 512 MB
    DirectX: Version 9.0c
    oder dieser
    Recommended:
    OS: Windows XP/Vista/7/8
    Processor: Dual Core 2.8 GHz
    Memory: 4 GB RAM
    Graphics: GeForce oder vergleichbare ATI mit 1024 MB
    DirectX: Version 9.0c
    Ruckelfrei Spielen kann wen ich mit meiner Hardware die ja doch ein ganzes Stück höher ist Meine Pc Daten:Prozessor AMD FX-6100 SIX CORE 3,3 GHZ;
    RAM Speicher 6GB;AMD Radeon HD 7800 Series mit 2 Gb Videospeicher, Windows 7 solche Probleme habe. Ich bin ein Grosser Fan von Omsi was man ja auch bei meinen Videos sieht aber ich bin mehr als Angefressen den bei den Vorab Lest Play sah es so aus alls ob alles ganz Geschmeidig lief und was ist mit den gekaufen Addons habe viel Geld Bezahlt und würde die gerne in Omsi 2 Haben den nur dort funktioniert der Gelenkbus so das wars mal lg martin

  • Hallo,


    nach ähnlichen Problemen wie oben beschrieben, hab ich bei Steam das Spiel auf Fehler prüfen lassen.


    Nach 2 Minuten kam die Mitteilung, dass 255 Dateien fehlten und diese nachgeladen wurden. Jetzt läuft es für´s Erste ohne Probleme.
    (45 Minuten Spielzeit).


    Für die, die es auch mal probieren wollen, Rechtsklick auf das Spiel -> Eigenschaften -> Lokale Dateien -> Spieldateien auf Fehler überprüfen.



    Gruß Preusse1985

  • Also meine Beobachtung war jetzt, nachdem ich die Sichtweite erhöht habe läuft es sehr viel Flüssiger, da der Rechner wohl viel Früher alles in den Speicher laden kann, probiert es mal aus.


    Und bei Steam habe ich das ebenfalls mal getan, sprich die Daten überprüft und er musst ebenso 226 Dateien nachladen.


    Aber ich habe das mal Getestet also danach OMSI2 gestartet eine Route ausgesucht und geladen und bin ein paar Meter gefahren und habe OMSI2 beendet, danach habe ich Steam wieder die Dateien Prüfen lassen und siehe da es waren wieder 65 Dateien die gefehlt haben, aber es scheint das nach jedem Start von OMSI2 anscheinend dann Dateien fehlen, weil nach jedem Laden von OMSI2 und anschließender Prüfung findet er immer wieder Dateien die nachgeladen werden müssen ??

  • Bei mir stand nach 1,5 Stunden gemütlichen Fahren nicht, dass sie fehlen, sondern das 38 Dateien nicht geprüft werden konnten und nachgeladen wurden.


    Diese Phänomen zeigt Steam allerdings auch bei der ungefähr jedem zweiten Steam-Spiel.
    Inwieweit das eine Steam-typische Angelgenheit ist, vermag Ich nicht zu beurteilen.


    OMSI 2 funktioniert bis auf einige Bugs weiterhin solide.
    ( KI-Busse fahren am U-Bahnhof Ruhleben durch den eigenen Bus

    ^^

    )


    Gruß Preusse1985

  • hab das selbe getan und bei mir sind es sage und schreibe -> 416 Dateien <- die nicht geprüft werden konnten und neu angefordert werden müssen...

  • Was sagt mir denn die Fehlermeldung :


    Zugriff bei Adresse 00569B2C in Modul omsi.exe. Lesen von Adresse 00000026


    Danke im Voraus

  • Ständig schmiert es ab, egal ob beim nachladen von terrain oder einfach so.... es ist nicht spielbar und ich bin mittlerweie echt sauer... flüssig ist es, aber dennoch schmiert es ab... Geld bezahlen aber ein unfertiges Produkt erhalten, bitte nachbessern,

    Was zum testen? - Nur her damit ;-)


    :busstop: Grüße aus dem schönen Marburg an der Lahn! :bus:


    <a href="http://fb.com/cvm.marburg"></a>

  • Ich "hatte?!" auch extreme Probleme OMSI 2 ordentlich zum Laufen zu bringen. Sämtliche Grafikfehler ( flimmern )... Ruckeln... Hänger.. Zugriffsverletzungen... etc etc..


    Nun habe ich folgendes gemacht: Ich habe in OMSI 2 selbst die Voreinstellung 2013 gewählt ( höchste ) ... gespeichert und Spiel beendet. Danach habe ich den Nvidia Inspektor gestartet.. ein neues Profil angelegt, EXE zum Spiel hinzugefügt und meine Einstellungen gemacht:



    Habe danach VORERST und bis jetzt keinerlei Probleme mehr feststellen können.


    Mein System:


    i7 3930K
    16 GB Arbeitsspeicher
    GeForce GTX 660 Ti


    vielleicht hilft es ja den ein oder anderen weiter.


    Lieben Gruß

  • Ich habe keine Probleme und laufe in Spandau mit 20 Frames konstant, außerhalb von der City Spandau sind es 30 Frames (festgestezt), kein Fahrzeug springen usw.


    System: i5 2500k 3.3Ghz
    8GB RAM
    GTX 570
    HDD
    Windows 7
    Track IR
    G27


    Ich habe auch keine weiteren Probleme, ich habe in der Nvidia Control, erst alles auf Qualität gestellt bei Bildeinstellungen in der Bildvorschau -> Meine bevorzugte Einstellungen
    In Omsi selber, die Hamburg Settings gewählt, damit läuft Omsi2 sehr gut.


    Bitte prüft auch ob andere Programme im Hintergrund laufen, habe alles was ich nicht brauche aus gemacht, Steam läuft im Online Modus.

    Wo die Logik aufhöhrt, fängt die Bahn an :)

  • Ich habe heute mal die selben Einstellungen wie in Omsi 1 verwendet.


    In Grundorf habe ich etwa 25 FPS mit dem NG, in Omsi 1 hatte ich 30 FPS. Da der NG aber sicherlich mehr Performance braucht, ist dies nicht schlimm.


    In Spandau habe ich zwischen 15 und 25 FPS, je nach Stelle. Das komische ist ja, es läuft bei mir flüssig, aber alle 10 oder 20 Sekunden gibt es einen Ruckler, der bis zu 3 Sekunden gehen kann und dann geht es wieder ganz normal.

  • Quote

    In Omsi selber, die Hamburg Settings gewählt, damit läuft Omsi2 sehr gut.

    sorry aber wo finde ich die settings weil ich finde die nicht

    :whistling:

    Windows 10 64-Bit
    Intel Core i7 6700 3,4 GHz
    Nvidia GTX 1070
    16 GB Ram
    SSD

  • Die hat man glaube ich nur im HH-Addon

    Здесь кто-нибудь говорит по-немецки?

  • Mich verwundern diese extremen Performanceschwankungen etwas. Mich würde mal interessieren ob M&R nur auf Intel getestet hat oder auch auf AMD. Scheinbar haben nur Leute mit AMD Systemen so extreme Probleme.


    Das sollte man in einem extra Thread behandeln, scheint mir jedenfalls ein sinnvolles Argument zu sein und bedarf einer genaueren Prüfung.

  • Hi, Nachdem ich nun endlich bei Aerosoft mit Rabatt mir OMSI2 kaufen konnte, hier mein "Bericht"/meine "Beschwerde". Ich hoffe auf zur kenntnisnahme und evtl. Antwort von Marcel/Rüdiger. Danke.


    Mein System:
    AMD Athlon x2 64 3ghz
    2 GB Ram
    2x 500 GB HDD
    ATI Radeon HD 6850
    Windows 6 Ultimate 32Bit


    Gleiche Einstellungen wie in OMSI1, und ich kann Berlin nicht spielen.. 5fps sobald ich einen Bus platziere - dieser springt dann schön rum.
    In OMSI1 hatte ich auf der Berlin Karte 18-22 FPS. Soviel dazu, das Multicore nun die Performance Probleme von OMSI1 behebt.. bei mir ist das gegenteil der fall.


    Der PC ist von 2008! Selbst mit den 2006er einstellungen komm ich bei OMSI2 nicht weiter. Super gemacht Marcel & Rüdiger, ich hoffe da kommt nochmal ein Performance Update!!


    Wieso denkt nur alle welt heutzutage im Americanischen Style "Immer Schneller, Immer mehr, Immer Besser".


    Dabei stand bei den Minimalen anforderungen "ab 2 GB Arbeitsspeicher".. hm ich würd sagen mein PC fällt in die Mindestanforderungen!
    Ich denke ein Spiel sollte im vollen umfang lauffähig sein, sobald die Mindesanforderungen erfüllt sind. Ich kann OMSI2 wie viele hier jedoch leider nur halb verwenden. Grunsdorf Funktioniert zumindest flüssig.


    Nun gut, schaun wir mal was in den nächsten tagen so passiert.


    MFG
    Stefan (30j.)


    edit: nach langem basteln hab ich nun maximal 10-15 fps in berlin solang ich mich vom rathaus fern halte, was schwerlich möglich ist. ich hab einfach mal alles runtergestellt, objekte, autos, busse.. also 2006er einstellungen nochmal extrem kastriert.. das is echt nich lustig.. omsi1 spandau lief ja auch mit 18-20.. Patch pls! Übrigenst hab ich auch getestet was den multicore angeht.. mit und ohne ist bei mir egal! die fps ändern sich dadurch nicht! die funktion hat bei mir keine wirkung.