[OMSI2] Editor: Fragen, Antworten, Neuerungen

  • Da es noch kein SDK gibt, sammele ich hier erstmal alle Neuerungen, die den Map-Editor von OMSI 2 betreffen. Außerdem könnt ihr hier Fragen zu den Neuerungen (nur!) posten, welche ich dann ggf. bearbeite/aufnehme.


    Fragen:


    • Es gibt keinen Button mehr, mit dem man sämtliche Objekte laden kann! - Dafür aber kann man alle Objekte eines bestimmten Ordners laden - was unserer Meinung nach wesentlich sinnvoller ist.
    • Warum funktioniert das Andocken an bestehende Splines nicht mehr? - Abgesehen von einigen Bugs, die leider noch vorhanden sind, muss man ab sofort Strg drücken, während man andockt. Dies hat den Vorteil, dass man ansonsten weiterhin präzise arbeiten kann, ohne dass einen die Snap-Funktion nervt. Allerdings muss man F9 separat und "blind" drücken, also wenn man gerade NICHT [Strg] drückt. Geht aber trotzdem, auch wenn es sehr merkwürdig ist, zugegeben...
    • Warum legen die Busse an selbsterstellte Bushaltestellen nicht mehr richtig an? - Leider ist uns ein Fehler beim Default-Wert unterlaufen: Die neuen Bushaltestellen können auch für Linksverkehr genutzt werden - was nun leider der Standardwert ist. Bitte in den Eigenschaften ganz unten eine "1" für Rechtsverkehr eintragen.Mein Fehler: Die Testkarte war mit [LHT] gekennzeichnet! ;) Dann drehen sich die Standardwerte natürlich um, hatte dieses sinnvolle Feature schonwieder vergessen...


    Neue Features:


    • [LHT] in die global.cfg eingetragen macht aus der Karte eine Linksverkehr-Karte. Allerdings müssen die Kreuzungen und Splines manuell umgebaut werden, dies geschieht nicht automatisch.
    • Splines können miteinander verbunden und voneinander getrennt werden - Hierzu den Button "Set New Parent..." verwenden und wahlweise den neu zu wählenden Vorgängen anklicken - oder nichts, um die Spline zu lösen. Allerdings ist die Funktion bisher nicht fehlerlos, weshalb sie noch mit Vorsicht zu genießen ist.
    • Splines können geteilt werden - Hierzu den Button "Split" verwenden und entlang der Spline den Teilungspunkt anklicken.
    • Splines können nun einen definierten Höhenunterschied überbrücken - Hierzu den Haken bei "delta h" anklicken und einen Wert eingeben (und mit Enter bestätigen).


    Die Listen sind bisher nicht vollständig.

  • Wie wechselt man dann den "Andockpunkt"? F9 hat bei mir leider keine Funktion mehr.


    Der Andockpunkt wird gewechselt, indem du F9 drückst und danach wieder die Strg-Taste zum Andocken gedrückt hältst. Während du F9 drückst, hältst du die Strg-Taste also nicht gedrückt.

  • Wieso gibt es bei den Fahrplänen 2 Typen zum Track erstellen? Oder hängt das mit der Chronologie-Funktion zusammen?

  • Das ist richtig. (Jedenfalls ist das bei mir genauso).
    Gehst du allerdings im Editor einmal über die ganze Map drüber, sind alle Objekte in der Liste vorhanden.

    Ihr benötigt Hilfe rund um den Bereich Omsi --> Für PN's bin ich immer offen.
    Grüße O407-Fan


  • Da ist auch ein Fehler in der Pfadangabe!! ...map\.roadmap.bmp - Schätze den Punkt kriegt Windoof nicht aufe`n Schirm.
    Eventuell ein kleiner Fehler der sich im Update Eingeschlichen hat ?(
    Versuch mal Windows zu Überlisten. Öffne dein Paint, gehe auf Neu, dann Speichern unter: .roadmap.bmp und verschiebe diese Datei ins Verzeichnis: ...texture\map
    Dann Starte den Editor mit Administratorrechten und probiere es mal aus. Vielleicht klappts ja.

  • Nein, das Problem ist, dass diese (inoffizielle, weil nur im Testbetrieb laufende!) Funktion nicht mehr mit der Tatsache klarkommt, dass die Kacheln teilweise nicht geladen sind. Ich werde das Problem aber in die Todoliste aufnehmen, weil die Funktion ja durchaus ihre Reize hat! ;)

  • Habe es jetzt so probiert:
    Schritt 1: Die Gesamte Map abgehen das alles geladen wird
    Schritt 2: Create Roadmap


    Dann geht es jedeoch ist die Roadmap unvollständig, das heißt nur Teile sind vergübar

    Meine Projekte: Autobahnmap V1 (Released) - The next Autobahnmap
    Weitere Games: ETS 2 - Multiplayer; Arma III

  • Ich habe ein kleines Problem:
    Ich habe selber eine Test-Map erstellt. Im Editor funktioniert alles einwandfrei!
    Aber sobald ich die Map in Omsi laden will, erscheint diese zwar, aber die Fehlermeldung "Fehler bei der Berichtsprüfung" erscheint und ist nicht wegzuklicken. Das geschieht auch bei der beigelegten Test-Map. Sowie auch bei eigenen.



    Ist das ein Fehler, oder muss man in Omsi2 noch etwas beachten, wenn man Maps erstellt?

  • Wenn du eine Map von Omsi 1 nach Omsi 2 Kopierst, ist doch der TTData- Ordner(Fahrplandaten) schon mit dabei.
    Wenn du die Omsi 1- Map im Editor von Omsi 2 das erste mal Lädst, musst du sie als erstes Abspeichern(dadurch wird sie Konvertiert ins Omsi 2- Format), danach
    Editor beenden und die Map erneut Laden. Dann solltest du eigentlich Zugriff auf die Tracks und Tripps haben.

  • Zu den "Neuerungen" gleich mal eine Anmerkung:


    Es ist super dass man in den Profilen das Handling an den Haltestellen einstellen kann, also Halte immer, Warte auf Abfahrtzeit etc. Da die KI ja gerne (auch in Spandau!) an Haltestellen vorbeirauscht sind ja arge verfrühungen an der Tagesordnung, die man aber mit "Warte auf Abfahrtzeit" an bestimmten Stellen bändigen kann. Unschön ist aber dabei dass die Busse dann öfters den Motor ausmachen wie an den Endstellen. Vielleicht sollte man hier entweder den Punkt "warte auf Abfahrtzeit und mache den Motor aus" einführen ansonsten den Motor eben nicht ausmachen, oder man sollte den Schwellenwert für das Ausmachen des Motors erhöhen: bei mindestens 3-4 Minuten Verfrühung bzw. Differenz zur planmäßigen Abfahrtzeit Motor aus, ansonsten nicht. Oder dieses Verhalten über die Optionen variabel lassen.


    Die "Anlegeentfernung" sollte auch mal überprüft werden, irgendwie ergeben dort eingetragene Werte keinen Unterschied. Wo früher zumindest zwei Doppeldecker sauber hintereinander halten konnten an einer Haltestelle kriegt es heute manchmal nichtmal ein Bus hin. Schön zu beobachten vor allem an Stellen wo die Entfernung zwischen Pfadsegment und Haltestellenwürfel etwas groß ist, beispielsweise am Terminus Ruhleben oder an der Galenstraße in Spandau (da ist aber eh der Wurm drin, die E522-KI's halten garnicht, fahren durch und verschwinden dann).

    Viele Grüße,


    wurstbrot

  • @ Marcel Kuhnt
    Nach dem Aktuellen Update funktionieren nun die Roadmaps wieder!

    Meine Projekte: Autobahnmap V1 (Released) - The next Autobahnmap
    Weitere Games: ETS 2 - Multiplayer; Arma III

  • Hallo liebe Omsi Gemeinde,

    Ich habe das Problem das ich eine Maps im Editor Laden kann.
    Ich habe ein mal Sittingen für Omsi 2 geladen und da ging es.
    doch jetzt habe ich das Problem er zeigt immer am anfang an "wollen sie dort weiter machen wo sie aufgehört haben" ich klicke dann immer auf nein.
    Dann zeigt er mir den omsi 2 Ordner und ich klicke wie im Omsi 1 Editor auf die global.cfg der jeweiligen Map.
    Darauf verschwindet das Fenster kurz und öffnet sich nach 1-2 Sekunden Wieder bitte um Hilfe! :busstop_small: :busstop: :sd: :busold: :bus:

    Hier gibt es nichts zu sehen! :P


    KEINE ANFRAGEN!!