[OMSI2] Editor: Fragen, Antworten, Neuerungen

  • Um es noch einfacher zu machen: ist im Aerosoft-Shop gaaanz unten zu finden.

    Satzzeichen retten Leben: Komm, wir essen Opa! - Retten würde ihn: Komm wir essen, Opa!
    Einmal mit Profis arbeiten... *seufz*
    Erstelle professionell gesprochene und produzierte Ansagen - auch für reale Verkehrsbetriebe.

  • So langsam gehen mir die Ideen aus...


    [Vorgeschichte]
    Habe mir kürzlich eine SSD-Platte gegönnt, dort Win7 64bit installiert und abgesehen davon, dass es mir dabei das alte 32bit-System auf der HDD zerschossen hat, hält sich mein Ärger über die moderne Technik in Grenzen. Immerhin sind sämtliche Daten auf der HDD noch erreichbar, nur das OS streikt.
    [/Vorgeschichte]


    Tja, und nun läuft OMSI selbst zwar altbekannt gut, aber der Editor nicht mehr. Genauer gesagt ist es das elende Problem mit dem immer wiederkehrenden Öffnen-Dialog und der Unmöglichkeit, Objekte und Straßen zu platzieren, sollte man die Karte doch geladen bekommen (z.B. über den manuellen Eintrag in der laststn_editor.osn).


    Die bisherigen Tricks (Starten -> letzte Karte laden -> beenden -> neustarten; als Admin ausführen; erst OMSI starten, wieder beenden und Editor starten, ...) haben bisher nichts genutzt und mehr finde ich auch grad nicht im Internet. Nächster Gedanke war dieser Could-not-lock-lightmap-Fehler, aber der fällt auch weg mangels Logfileeintrag. Ein Start vom alten Installationsort (eine Partition der HDD) weg brachte ebenso wenig, am Installationsort der neuen Installation (unter C:\Programme) kann es also auch nicht liegen. Man könnte fast auf die Idee kommen, dass der Editor keine 64bit-Systeme mag, denn auf meinem Laptop mit Win8.1 läuft er auch nicht... aber irgendeine Lösung, die ich nicht kenne und auch grad nicht finde, muss es doch noch geben :S


    Da ist man einmal grad so schön im Baufieber und dann sowas... :pinch: Ich hoffe ja, dass sich da bei einem nächsten OMSI-Update auch am Editor nochmal was verbessert...

  • Hast du es schonmal mit dem Kompatiblitätsmodus versucht?
    Ich habe auch Windows 8.1, 64bit und alles läuft zu meiner Zufriedenheit.

    Windows 10 64bit | i5-8600K, 6x 3.6 GHz | 8 GB RAM | GTX 1050Ti | 250GB SSD

  • Ich bin nun alle möglichen Kompatibilitätsmodi durch, leider keine Besserung, weder unter Win7 noch Win8. Letzteres ist aber auch nicht tragisch, weil ich am Laptop sowieso nicht bauen werde und mein normaler PC kein Win8 bekommen wird.


    Fall jemand mal einen Blick werfen möchte hier die Logdatei nach Editorstart mit vorheriger Karte und Ladeversuch einer beliebigen anderen Karte über Map -> Load. Mehr als "Error: Map could not be loaded" will OMSI leider nicht verraten, aber das sehe ich ja schon selbst :D


    Einzige echte Auffälligkeit sind die Zeilen 19 und 81. In ersterer steht "Load [gobal.cfg der Karte] map...", beim Ladeversuch der andere Karte steht nur "Load map...". Scheinbar wird also der Dateiname nicht richtig ins System übernommen.

  • Nein, habe ich nicht. Nur die Neuinstallation von Windows mit anschließender Neuinstallation von OMSI und Rückkopieren der Ordnerinhalte :D


    Es tritt auch nicht nur bei einer bestimmten Karte (= meiner) auf, sondern generell bei allen. Er lädt immer nur die Karte, die in der laststn_editor-Datei enthalten ist. Ändere ich den dortigen Eintrag, ist ein Laden anderer/meiner Karten problemlos möglich, allerdings kann ich dann keine neuen Objekte und Splines laden, sondern nur die schon vorhandenen verwenden. Hier vermute ich Parallelen zum nicht korrekt übergebenen Namen der jeweiligen global.cfg, sprich programminterne Probleme bei der Übernahme eines Dateinamens aus dem Öffnen-Dialog. Warum es allerdings mal (also bisher) geht und mal nicht und bei jedem Nutzer unterschiedlich...


    Prinzipiell könnte ich also mit den Objekten/Splines arbeiten, die enthalten sind und neue einfügen, indem ich sie manuell in die Kacheldateien eintrage. Ist machbar, aber umständlich und natürlich nicht gerade die Art Lösung, die ich suche ;)


    Ich werde nachher OMSI nochmal runterwerfen, neuinstallieren und den Editor testen, bevor ich die Ordnersicherung zurückspiele. Ich hege zwar nicht viel Hoffnung, aber vielleicht geht es ja dann doch wieder ohne mörderische Umwege.

  • Das ist Standard-Content von OMSI, in Windows heißt der Ordner in Sceneryobjects "Kreuz_MC". In der Editor-Liste heißt das "Crossings", dort sind nicht nur Kreuzungen sondern auch Einmündungen (Junction) zu finden.

    Satzzeichen retten Leben: Komm, wir essen Opa! - Retten würde ihn: Komm wir essen, Opa!
    Einmal mit Profis arbeiten... *seufz*
    Erstelle professionell gesprochene und produzierte Ansagen - auch für reale Verkehrsbetriebe.

  • Ich habe ein Tutorial für dem Omsi 1 Editor gesehen. Da war ein Ordner mit Crossings https://www.youtube.com/watch?v=sGUenMZVrn4 ca: 3.25 Minuten und meine Frage ist ob es ein Addon ist oder dieser Ordner im Omsi 2 Editor nicht mehr vorhanden ist.
    MfG Tim


    Der "Crossings"-Ast des Baumes ist dann vorhanden, wenn entsprechende Objekte geladen wurden, z.B. aus dem Ordner "Kreuz_MC".

  • Und nochmal eine Frage. Ich versuche mich gerade in den Editor zu reinzuknobeln oder wie man es sagt. Also hier nochmal das Tutorial https://www.youtube.com/watch?v=sGUenMZVrn4 bei 5:32 kann er einfach die Straßen verbinden. meine Frage ist wurde das im Omsi 2 rausgenommen? Mit "Complete To" kann ich bei sowas nichts anfangen weil dann immer noch eine kleine Kurve drin ist. Oder muss man einfach Milimeterarbeit machen?

  • STRG Taste zum verbinden. Sollte die Verbindung nicht passen mit F9 kann man durch die Pfade wechseln. Aber nie STRG & F9 zusammen drücken.

    Hole Dir diesen Thread jetzt für nur 4,99 € im Sparabo auf Dein Handy!
    Schicke "I D I O T" an Deine eigene Handynummer!

  • Ich habe im Editor beim bauen versehentlich auf "Set New Parent" geklickt und kann jetzt auf der dieser Kachel die Andockfunktion bzw. die Complete to-Funktion nicht mehr nutzen. Leider habe ich auch kein passendes BackUp um es wieder auf den alten Stand zubringen. Deswegen meine Frage: Gibt es eine Möglichkeit herauszufinden, welche Splines sich durch das klicken miteinander verbunden haben und eben einen neuen Andockpunkt gesetzt haben?

  • Guten abend ich habe folgendes Problem beim erstellen Von mein Fahrplan.


    Beim erstellen des Farhplans habe ich alles erstellt nun habe ich das problem das wenn ich Edit Timetable... öffne und ein fahrplan erstelle ,
    dann kann ich nichts bei trip eintragen es kommt immer meine schon fertige linie die schon Funktioniert.
    wenn ich dann auf show all gehe zeigt er mir meine neue linie an, die wehle ich aus und dann Verschwidet sie einfach wieder .
    Und zeigt mir wieder die aller erste linie an die schon fertig ist. Kennt jemand das problem?

  • Hallo zusammen. Gibt es eine Möglichkeit, wenn man versehentlich den "Set New Parent"-Button gedrückt hat und nicht weiss an welcher Stelle, dies wieder zu entfernen? Ansonsten funktioniert die Andockfunktion ja nicht mehr.

  • Staaken79

    Added the Label [OMSI2]
  • Hallo liebe Omsi Fans ! Ich habe eine Frage und zwar kann man Kreuzungen mit Objekten verbinden funkioniert das weil ich habe es mit blender versucht aber es funkioniert irgendwie nicht oder muss ich die Häuser einzeln platzieren würde mich über eine schnelle antwort freuen danke lg EducatedGamer:)