''Lade'' Hänger

The forum is in reduced operation. The Addon and Support forums remain open.
Please note that OMSI is no longer under development. Some of the developers are now working on a new simulator. Further information concerning the LOTUS-Simulator can be found here.
  • Abend,


    ich habe folgendes Problem: Mein OMSI läuft ansich top (Spandau soiwe natürlich Grundorf). Doch gibt es seit dem neuen Update ein kleines Problem, was mich sehr stört. Ich bin nunmal ein sehr pingelinger Mensch

    ^^



    Beispiel:

    Ich fahre mit meinem Bus durch Berlin Spandau, habe so im Durchschnitt 30 - 35 FPS und dann kommen auf einmal am Horizont paar Objekte dazu und dadurch bekomme ich jedesmal ein Hänger.
    Ich psiele mit Kachel Einstellung 1. D.h. es sind immer 9 Kacheln geladen. Da läuft das Spiel top. Doch probiere ich 2 Kacheln aus (Die bekannte ''Einstellungen hochdrehen'' Therorie) doch da geht mein Rechner extrem in die Knie. Objektsichtbarkeit auf vielen Stufen ausprobiert. Habe es momentan auf 600. Ich habe echt keine Ideen mehr. Vor dem Patch ist mir zwar das Spiel teilweise so oft abgestürtzt, aber diese Ladehänger waren nicht da... Dieses Problem ist wirklich erst seit dem neuen Patch da.


    Hier ein kleines Video, wo man es deutlich sieht:


    http://www.youtube.com/watch?v=R7tuK1n4gok

  • Das kurze Einfrieren liegt daran, dass die Festplatte ausgelastet ist, da OMSI sehr viele Objekte laden muss. Eine normale HDD kommt da nicht mit. Wenn du eine SSD hast, dürfte sich das Ganze zum Postiven ändern, da diese extrem schnell sind und damit in kurzer Zeit sehr viele kleine Dateien laden und bewegen kann.

    Give a man a gun and he can rob a bank, but give a man a bank, and he can rob the world.

  • Hallo,


    bei Omsi 1 hat der Trick mit der SSD bei mir geholfen. Da sind die Nachladeruckler stark minimiert worden. Bei Omsi 2 sind die Nachladeruckler mit SSD schlimmer als bei Omsi1 mit HDD. Ansonsten hätte ich nämlich auch keine Probleme mit Omsi2.

    :(
  • Das war auch mein größtes Problem, versuche mal in den Optionen bei: Grafik (Erweitert) mit den Einstellungen der "Dynamischen Kachelreduktion" und
    des "Erzw. ökonom. Refl. Modus" zu Probieren.
    Am Anfang (auch noch nach den beiden Patches) lief OMSI 2 bei mir mehr als Bescheiden, jetzt ist es wie Ausgewechselt.


    Hier mal ein Bild meiner Einstelungen, damit du einen Anhaltspunkt hast. Den "Erzw. ökonom. Refl. Modus" habe Quasi deaktiviert und die Kachelreduktion
    springt jetzt auch nicht mehr so schnell an. Meine Grafikkarte (NVIDIA GeForce 210) kommt seitdem auch klar mit 900MB zugeordneten Speicherbedarf, kann also
    mehr Objekte laden ohne dass der Bus springt und lädt auch nicht mehr so Oft nach. Also bei mir läuft es so um Einiges Flüssiger.
    Dadurch kann ich mehr Kacheln laden und die Objektsichtbarkeit erhöhen. Seitdem sind die Ruckler bei mir auf
    ein minimum Reduziert, den Rest macht dann hoffentlich der nächste Patch.

    :D



    In Zukunft hier anzutreffen: https://reboot.omsi-webdisk.de/net/user/251-staaken79/

  • Könnte man ja mal versuchen,das Spiel von einem schnellen USB Stick laufen zu lassen,um zu sehen ob es wirklich an der festplatte liegt!!

  • Ich glaube auch Eher, dass bei den automatischen Reduzierungen irgentetwas noch nicht so ganz Rund läuft,
    habe ne alte Festplatte, nix mit SSD und es läuft jetzt flüssig.

    In Zukunft hier anzutreffen: https://reboot.omsi-webdisk.de/net/user/251-staaken79/

  • OK DANKE,aber es hat sich bei den Nachladeruckler kaum was verändert sind immer noch.Es sind aber weniger....schade,das man hier alles so runterstellen muss!!

  • Danke für eure ANtworten. Ich habe mich gerade ebend die ganze Zeit mit dieser Erzw. ökonom. Refl. Modus rumgefummelt und es bring alles nichts... So kann ich kein OMSI spielen

    :(


    Vielleicht wurde beim letzten Update was verfummelt? Weil davor ging es ja wunderbar...

  • Also Nachladeruckler hatte ich selber schon immer.


    Der Geheimtipp soll ja angeblich eine SSD sein, aber bisher konnte ich mich dazu nicht durchringen extra für OMSI eine SSD anzuschaffen, somit spiele ich trotz nachladeruckler weiterhin OMSI( 2 :D).

    ex OMSI Forum Moderator(circa 6 Jahre :O ).

  • Omsi 2 hat bei mir an den gleichen Stellen Nachladeruckler ( Spandau und Grundorf ), egal ob ich es auf meiner zugemüllten HDD oder meiner leeren SSD spiele. Das Problem muss irgendwo anders liegen und die vielen verschiedenen Einstellungsmöglichkeiten haben einen weitaus komplexeren Eingriff in die Performance als wir es verstehen.

  • In OMSI 1 gab es große Unterschiede ob man eine Festplatte benutzt, SSD oder RAM-Disk im Hinblick auf das Nachladen. In OMSI 2 scheint es aber so zu sein dass nachdem die Daten geladen wurden noch irgendwas rumgerechnet wird, daher merkt man da wohl kaum Unterschiede. Und dieses Verhalten hat sich seit dem Patch verschlimmert, sodass gerade SSD-Nutzer hier einen großen Unterschied zu vorher merken.


    Dass hier Threads die auf einem anderen Kern laufen auf Ergebnisse eines anderen Threads vom anderen Kern warten kann auch nicht wirklich sein, denn schaltet man die Multicore-Unterstützung aus verhält sich das Nachladen ebenso stotternd wie bei aktiver Multicore-Unterstützung, nur die FPS gehen halt runter.

    Viele Grüße,


    wurstbrot

  • Kann auch die selben Probleme (seit dem letzten Patch!) sehr wohl bestätigen. Das Deaktivieren des Multithreating (war niemals bei mir an) hat auch nichts gebracht. An den genannten Einstellungen habe ich auch schon Weiß-der-Geier was ausprobiert, leider auch ohne Erfolg. Meiner Meinung nach liegt das ja, wie bereits erwähnt, an dem Nachladen der Kacheln, was nicht flott genug geht.


    Habe mir vor 4 Monaten einen komplett neuen Rechner besorgt, an der Leistung kann es definitiv nicht liegen - auch bei den Standardeinstellungen 2006 habe ich diese Nachlade-Beschwerden.

  • So, ich habe jetzt wirklich alles versucht. Habe meine Festplatte fragmentiert (die wird eh alle paar Tage automatisch fragmentiert), neu installiert und an jeder Einstellung rumgefummelt.
    Es kann einfach nicht sein, dass es vor dem ersten Patch besser lief als nach dem Patch. Die müssen noch irgendwas verfummelt haben. Und etwas neues zu kaufen (z.B. eine SSD) sehe ich nicht ein! Es lief vorher top, also hat es auch jetzt top zu laufen! Jedes andere Spiel läuft auf meinem Rechner super, warum OMSI2 dann aufeinmal nicht?

  • Du solltest eine Festplatte HÖCHSTENS alle 2 Monate defragmentieren! Ansonsten wird der Schreibkopf unnötigerweise benutzt und die Festplatte altert im Zeitraffer.

    Give a man a gun and he can rob a bank, but give a man a bank, and he can rob the world.

  • Hmm.. Komisch, warum das von Wondows 7 so standartmäßig eingestellt ist...
    Aber was hat das jetzt mit meinem Problem bei OMSI zu tun? Ich bin wirklich kurz davor, den Kram irgendjemanden zu schenken den ich bis zum Tot hasse. Dann kann der sich nämlich damit rumquälen.

  • Ladehänger haben bei mir zu einem Absturz geführt, jetzt nach dem Patch geht alles wieder, bei einem Pc von mir.
    Core Duo 3Ghz , GTX 460, 4gb Ram


    Ps: Defragmentierung haben meine Platten immer ausgehalten, die älteste ist jetzt 10 Jahre, so viel dazu.

    Alle meine " beiden " Pc´s haben
    I7-6700K, Nvidia 1070 8mb, 16 Gb Ram, und jeder PC hat jeweils, 3 SSD´s verbaut.

  • Ich kann die Erfahrungen hier bestätigen, mich nerven die Laderuckler extrem...


    Daher bin ich auch voller Hoffnung am Wochenende auf eine SSD umgestiegen, doch selbst auf einem neuen System und nagelneuer SSD sind die Laderuckler nicht wesentlich weniger zu spüren. Nur wenn ich die Kachelanzahl erhöhe wird es etwas weniger, jedoch lässt das mein aktuelles System kaum zu, weil mich das gut und gern dann 10-15FPS kostet.


    OMSI 1 habe ich spasseshalber installiert, und das läuft mit der SSD hammermässig.

    BAUMI's Repaintecke, Repaints aus dem Münsterland und dem Osnabrücker Land!


    hier im Forum!