Abstürzen bei DG_RefreshNearLinks | Update: Logfile von Ahlheim

  • Hallo!
    Ich habe ein Problem, dass Omsi manchmal, und in unregelmäßigen Abständen abstürzt. (Nichts geht mehr, Omsi reagiert nicht mehr und muss über den Taskmanager beendet werden.
    Mir ist aufgefallen, dass es warscheinlich immer dann abstürzt, wenn in der Info-Zeile etwas von DG_RefreshNearLinks steht.


    Vielleicht weiß jemand, was Omsi da macht, oder ob es an der Karte oder an Omsi selber liegt.
    Das Problem tritt bis jetzt bei allen Bussen und bei allen Karten auf. (Berlin ist auch betroffen, ebenso hatte ich mit dem NG auf Sittingen mal ein Problem). Es liegt auch nicht daran, dass die Karte zu komplex ist, denn, als ich den Absturz auf meiner eigenen Karte hatte (s. Bild), naja, da ist absolut nichts, außer Bäume & Straße.


    PS: Einstellung runterschrauben hilft nicht. :rolleyes: Es tritt auch an verschiedenen Stellen der Karte auf, deshalb ist das Problem so gut wie nicht zu rekonstruieren, das einzige, was ich habe, ist diese Meldung mit DG... (s. Bild)


    Viele Grüße
    Rumpelhans 104



  • Es tritt auch an verschiedenen Stellen der Karte auf, deshalb ist das Problem so gut wie nicht zu rekonstruieren, das einzige, was ich habe, ist diese Meldung mit DG... (s. Bild)


    Und Du hast das Logfile!
    Bitte Poste Deine Logfiles, nachdem der Fehler Aufgetreten ist.

  • Hatte ich vergessen, steht aber auch nichts drin, was hilfreich sein könnte :rolleyes:

  • Es steht doch etwas drin, was interessant sein könnte..

    140 08:52:49 - - Warning: Busstop Wackenberg/ found no exiting path!
    141 08:52:49 - - Warning: Busstop Regionalbahn 1/ found no exiting path!
    143 08:53:36 - - Warning: Busstop Wackenberg/ found no exiting path!
    144 08:53:36 - - Warning: Busstop Regionalbahn 1/ found no exiting path!


    Hier finden die Busstopwürfel keinen Pfadweg. Soweit ich das richtig interpretiere sucht der Busstop beim <DG_RefreshNearLinks> einen Path in seiner Nähe. Wenn er diesen nicht findet, kackt OMSI scheinbar ab. Überprüfe mal die Pfadwege die direkt an dem Busstop liegen. Evtl. auch die Linienwege, die dort an der Haltestelle anhalten sollen.

  • Hast du die Spieldateien schon mal auf Fehler Überprüfen lassen?
    In der Tat scheint Omsi bei Dir Probleme damit zu haben, einige Pfade zu Laden. Und da es bei jeder Map und jedem Bus, passiert gehe ich mal davon aus, dass eine Datei von M&R beschädigt sein könnte.
    Vielleicht eine Fehlerhafte Spline von M&R, die in jeder Map, die Du probiert hast, verbaut ist.

  • Es steht doch etwas drin, was interessant sein könnte..


    Hier finden die Busstopwürfel keinen Pfadweg. Soweit ich das richtig interpretiere sucht der Busstop beim einen Path in seiner Nähe. Wenn er diesen nicht findet, kackt OMSI scheinbar ab. Überprüfe mal die Pfadwege die direkt an dem Busstop liegen. Evtl. auch die Linienwege, die dort an der Haltestelle anhalten sollen.

    Ja, das kommt mir auch komisch vor, vor allem deswegen, weil
    a) Der Name des Würfels ohne das "/" hintendran steht
    b) Wackenberg nur 2 Station-Links hat (keinen Trip, also auch nix Fahrplan)
    c) Der Würfel Regionalbahn 1 genau auf einem Pfad liegt (s. Bild)
    und d) Es einen zweiten Würfel namens Regionalbahn 2 gibt, der exakt so platziert ist, wie der 1er, nur an einer anderen Stelle. Da gibt's das nicht.


    Könnte es evt. möglich sein, dass man die entsprechenden Kacheln zu "schnell" passiert, sodass Omsi eigentlich noch die Pfade ausrechnet, während man aber schon längst auf dieser Kachel steht?


    PS: Seit Steam die Dateien überprüft hat, ist es bis jetzt zu keinem neuen Fehler mehr gekommen. Hoffentlich bleibt's auch so...


  • So, heute wieder der Fehler - Diesmal auf Ahlheim.


    Edit: Der Fehler ist um 14:08 aufgetreten, also seit 4 Minuten keine neuen Log-File-Einträge.


  • Scheint eine echte Krankheit zu sein, dass OMSI2 Texturen, Sounddateien etc. nicht finden oder laden kann und dann abstürzt. :huh:

  • Ja Omsi wurde scheinbar verhunzt ^^


    Wenn ich Omsi spielen will sieht das so aus.


    -Lenkrad holen
    -Lenkrad aufbauen
    -Omsi starten
    -Stettin laden
    -Fahrplan auswählen und Abfahrtszeit abwarten
    :D
    Hier sind bereits 7 Min vergangen


    -Omsi spielen
    -Nach 4 Min absturzt (wie oben beschrieben)
    -Lenkrad abbauen
    -Lenkrad wegpacken
    -Tera spielen


    Leider ist das traurige Wahrheit, und so war es auf Stettin vorgestern. Is wurst auf welcher Map ich fahre, kann auch Spandau sein, schmiert genauso ab.


    Liebe Grüße

  • Also

    Ich könnte meinen, es würde helfen wenn du OMSI im Kompaktibilitätsmodus startest. (Windows XP sollte gehen)


    ich habe es mal probiert denn an dieser stelle hängt es sich zwar nicht auf bei mir , aber dort kommen die starken Nachladeruckler :/


    Wenn ich es so Probiere mit den Win XP Kompi. kommt die Fehlermeldung "Intergierüberlauf"


    Liebe Grüße


  • Stimmt, es ist wirklich traurig. Egal, welche Map, immer stürzt's ab.
    Ich kann keine Linie mal ganz durchfahren, geschweige denn die Rückfahrt. :cursing: (Mal abgesehen von Grundorf und meiner Map, auf der das Problem leider aber auch besteht.)
    Es hängt irgendwie mit diesem DG_RefreshNearLinks zusammen, dann stürzt es ab. (Aber eine Erklärung habe ich nach wie vor nicht.)
    Insofern zocke ich i.M. eher den "Editor", um meine Map weiterzubauen ;)