Neue Erkenntnis zur Abwärtskompatibilität / Performance

  • Ich habe heute mehr oder weniger durch einen Zufall etwas entdeckt, was auch für die Entwickler interessant sein könnte:


    Die "alten" Ai-Listen (also die vom Typ 1) werden anscheinend in OMSI 2 nicht mehr unterstützt.


    Auf einer WIP-Map von mir gibt es noch keine Fahrpläne, auch an der AI-Liste ist nix gemacht. Starte ich die Map passiert folgendes:





    :rolleyes::huh::S
    ...Wie man also sieht fahren nur Busse durch die Gegend (das könnte auch die längere Ladezeit nach eigentlichem Laden der Karte erklären).


    Die AI-Liste ist, wie schon gesagt, eine aus dem Template, also vom Typ 1:


    Vielleicht könnte MR da nochmal nachschauen?
    Ich meine die AI-Liste schnell umzuschreiben ist kein großes Problem, nur vllt hängt da auch einiges bezüglich der alten OMSI1-Karten mit Listen vom Typ1 zusammen ;)



    Bis denne, viele Grüße
    Alex ^^

  • Zunächst, wenn du die Entwickler ansprechen willst, solltest du sie auch direkt informieren, z.B. über die eigenst dafür eingerichtete Mailadresse.


    Wenn du diskutieren willst:
    Warum funktionieren denn die alten ailists auf vielen anderen Strecken? Ist zwar logisch, die Probleme in der ailist zu suchen, aber da wird wohl noch irgendein anderer Effekt eine Rolle spielen müssen.

    Payware-Addon "Berlin X10" ist fertig.


    Als Download-Version, Box-Version, Special-Edition und bei Steam erhältlich.

  • Man kann doch auch ohne Vorlage eine erstellen, hier im Expertenforum gibt es dazu gute Erläuterungen. Warum jemand jetzt noch eine neue AI-Liste im alten Format anlegt, ist mir ehrlich gesagt auch schleierhaft. Allein die ganzen Zähler sind doch schon ein Graus, wenn man daran etwas ändern will.

  • Man kann doch auch ohne Vorlage eine erstellen, hier im Expertenforum gibt es dazu gute Erläuterungen. Warum jemand jetzt noch eine neue AI-Liste im alten Format anlegt, ist mir ehrlich gesagt auch schleierhaft. Allein die ganzen Zähler sind doch schon ein Graus, wenn man daran etwas ändern will.


    es gab doch hier im forum irgendwo einen konverter dafür, wenn ich mich nicht irre?

  • Mensch Leuties!


    Mir geht es immernoch nicht darum, dass eine neue AI-List ein Problem für mich zu erstellen wäre.


    Es geht mir nur um das Thema der Abwärtskompatibilität - viele OMSI 1-Karten verwenden noch die alte AI-Liste und möglicherweise funktionieren sie deshalb nicht vernünftig.


    War ja nur so als kleiner Hint gemeint. :)

  • Du widersprichst dir ein wenig selbst. Natürlich wurden viele Karten vor 1.04 angefangen und von denen danach sind auch welche im alten Format (siehe Schilderung Template). Ich für meinen Teil kann sagen, dass Teltow bzw. X10 Berlin bis 2014 im alten Format ist, ohne jemals Busse als Autos gehabt zu haben. Weit über 50% der Maps im Forum dürften auch das alte Format haben, hier wäre interessant, ob bei irgendeiner von ihnen das geschilderte Problem auftaucht.

    Payware-Addon "Berlin X10" ist fertig.


    Als Download-Version, Box-Version, Special-Edition und bei Steam erhältlich.

  • Mir ist zumindest noch nicht aufgefallen, dass AI-Listen im alten Format Probleme verursachen. Z.B. Gladbeck und Teltow (letztere Map mit Editor ins OMSI-2-Format konvertiert) laufen unauffällig.