Mainz, Karte und Fahrzeuge

The forum is in reduced operation. The Addon and Support forums remain open.
Please note that OMSI is no longer under development. Some of the developers are now working on a new simulator. Further information concerning the LOTUS-Simulator can be found here.
  • I have a question cause I noticed this at the krefrath map, but as the maker of the map suggested I might aswell ask here since its a bus of the Mainz map.

    :)


    I noticed that with many maps that have two or drie number lines, the Gelenk version and sometimes also the solo version often show only 1 or 2 numbers. For example the line 51 at krefrath it only shows the number 5 on the AI busses. See image below.

    I think it's because the system of the lions cuts off the last two digits from the line number. In Mainz the internat line consists of the "real" line and the route, eg "6861" for line "68" route "61". So you would have to change the IBIS/matrix scripts to get a standard behaviour. I think there is already a junction in the script (if map = mainz then cut off, else do not cut off...), but it does not seem to work right.

    Viele Grüße,


    wurstbrot

  • I think it's because the system of the lions cuts off the last two digits from the line number. In Mainz the internat line consists of the "real" line and the route, eg "6861" for line "68" route "61". So you would have to change the IBIS/matrix scripts to get a standard behaviour. I think there is already a junction in the script (if map = mainz then cut off, else do not cut off...), but it does not seem to work right.


    So its a little script error if it is stated in the script that it shouldn't cut down if its not mainz.

  • I use my own Fontfile for the Bus, it's build with the original Fontfile from the O405n2 from Julian. I have no problems with long Linenumbers etc.


    Und nochmal auf deutsch, weil men Englisch so schön verrostet ist.

    :D


    Ich habe mir auf dem originalen Fontfile von Julians O405N² ein eigenes Fontfile gebastelt. Das Ding ist auch schon ewig und drei Tage alt. Damit habe ich keine Probleme was Liniennummern etc. im KI-Verkehr angeht. Heute in Krefrath kam einer, der hatte brav 52 geschildert, wie er es soll.

  • I use my own Fontfile for the Bus, it's build with the original Fontfile from the O405n2 from Julian. I have no problems with long Linenumbers etc.


    Und nochmal auf deutsch, weil men Englisch so schön verrostet ist.

    :D


    Ich habe mir auf dem originalen Fontfile von Julians O405N² ein eigenes Fontfile gebastelt. Das Ding ist auch schon ewig und drei Tage alt. Damit habe ich keine Probleme was Liniennummern etc. im KI-Verkehr angeht. Heute in Krefrath kam einer, der hatte brav 52 geschildert, wie er es soll.


    Really, how did you do that then if I might ask ? Perhaps that would solve my issue aswell.

    :)
  • Really, how did you do that then if I might ask ? Perhaps that would solve my issue aswell.

    :)


    As I said, I use another Fontfile, based on the original Fontfile from Julians O405N2

  • Hallo,
    wie kann man beim LC die Verfrühung oder Verspätung im Ibis in Zehntelminuten anzeigen lassen?


    Wieso willst du das denn? Die Busse zeigen sie in der Realität auch nicht so an.

    ;)


    Abgesehen davon frage ich mich wirklich warum mans so genau braucht.

  • Bei mir wird leider überhaupt nichts außer eben der Himmel geladen. Ich habe mehrmals alle Addons, die benötigt werden neu installiert. Zumindest glaube ich, dass ich alles richtig gemacht habe.



    Über eine Hilfe wäre ich mehr als nur froh.

    Mit freundlichen Grüßen


    André Hergert

  • Warning: Spline wurde nicht gefunden: Splines\Yufa\BUS_text_s.sli, falls es sich um eine Addon-Karte handelt, lesen Sie bitte die Dokumentation und kontaktieren Sie ggf. den Autor. Falls es sich um eine originale Karte handelt (Spandau oder Grundorf), reparieren Sie bitte OMSI mittels Original-Setup.


    Hast du Yufas Splines?
    Wenn ja, dann musst du aus "Bus_Text", nachdem du dies kopiert hast, "BUS_text_s" machen.
    Wenn nein, dann lade dir diese erneut herunter.
    Ich hoffe, du kommst damit klar.

    Edited once, last by Michael ().

  • Hä, wo, wie, in welchem Ordner denn?
    Also bei mir ist da nichts mit "BUS_Test"


    Edit: Funktioniert nun doch. Super Karte und Busse! Gefällt mir echt klasse! Ich konnte den Fehler nach einiger Zeit herumschnüffeln im Forum finden. Ich habe zunächst versucht, in dem Splines Ordner unter Yufa die Datei umzubenennen. Dies gelingte mir jedoch nicht. Nach einiger Zeit bemerkte ich meinen Fehler: Ich hätte die Datei erst kopieren und einfügen müssen, und dann erst umbenennen.
    Für Leute mit dem selben Problem, deren Karte nicht geladen wird, glauben jedoch, alles richtig installiert zu haben, ist folgendes zu tun:
    Die Datei "BUS_text.sli" aus dem Ordner .../OMSI/Splines/Yufa kopieren und im selben Ordner wieder einfügen. Diese Kopie dann umbenennen zu "BUS_text_s.sli".

    Ich hoffe, ich kann hiermit einigen Leuten weiter helfen und bedanke mich mal sehr herzlich für diese Karte und die tollen Busse mit den super Sounds. Ein riesen [DANKESCHÖN!!! Die kleinen fehler die da bei den Bussen sind, bezüglich der I.Box und des Busses an sich, sind so gering, dass sie nicht wirklich sehr stören. Ich weiß, dass es sau schwer ist, eine Karte - und das auch noch in Real - und solche tollen Busse zu erstellen.


    Und noch mal Edit: Bei mir sind da zwei Probleme: Mir mir fehlen manche Texturen von einigen Straßenteilen. Das ist bei mir so weiß. Und das andere ist, dass wenn ich im Bus am IBIS die Linie eingebe und Enter drücke, steht da keine Linie. Da sollte man eigendlich dann das Dings da sehen und mit OK oder sowas bestätigen, sodass es an der Anzeige angezeigt wird, was bei mir leider jedoch nicht der Fall ist. Ich bitte also erneut um HILFE

    :!:

    Mit freundlichen Grüßen


    André Hergert

    Edited 3 times, last by André007 ().

  • @ Andre007


    Probier dieses mal aus.

    Intel Core i7-4790K, 4 x 4.00GHz Devil's Canyon
    32GB RAM, MSI GTX 1070 8GB
    Windows 10 (64 Bit)
    Logitech Driving Force GT / TrackIR 5
    LG aus Bochum, yellow69

  • Mit dem Schildern bekomme ich nun mehr oder weniger hin. Aber das mit den Straßen, dass manche, oder besser gesagt viele Teile weiß, also ohne Texturen sind, ist nach wie vor.


    Außerdem ist mir aufgefallen, dass manche KI Busse in andere KI Busse hineinfahren, wenn sie ein Gelenk haben. Kann man das bereits lösen oder muss das noch in einer weiteren Version verbessert werden?


    EDIT: Also mit dem Schildern bekomme ich immer noch nicht hin. Ich habe das nur mal hinbekommen, als ich einen KI Bus nahm. Aber bei einem eigenen geht das nicht. Wenn ich so zu schildern versuche, wie du mir gezeigt hast, bei dem, der auch so ein ähnliches Problem hatte, hilft das auch nicht. Ich bekomme immer "Falsche Route" angezeigt. Da steht dann höchstens die Linie richtig dran, aber da, wo das Zeil stehn sollte, leuchten unten nur eine Reihe von Punkten.

    Mit freundlichen Grüßen


    André Hergert

    Edited 5 times, last by André007 ().

  • Quote from 'André007

    Außerdem ist mir aufgefallen, dass manche KI Busse in andere KI Busse hineinfahren, wenn sie ein Gelenk haben. Kann man das bereits lösen oder muss das noch in einer weiteren Version verbessert werden?


    Nein, das liegt an den Invisible Splines, dann erkennt der eine Ki Bus den anderen nicht, weil sie nicht auf dem selben Pfad unterwegs sind.


    Bei Deinen anderen Fehlern, liegt es wie schon gesagt, das Dir einiges fehlt.

    Alle meine " beiden " Pc´s haben
    I7-6700K, Nvidia 1070 8mb, 16 Gb Ram, und jeder PC hat jeweils, 3 SSD´s verbaut.

  • Nein, das liegt an den Invisible Splines, dann erkennt der eine Ki Bus den anderen nicht, weil sie nicht auf dem selben Pfad unterwegs sind.

    Es gibt tatsächlich einige Parallel-Pfade, und leider nutzen manche StnLinks dann auch verschiedene. Hier fährt dann alles logischerweise ineinander rein, gut zu sehen in der Bahnhofstraße aus Richtung Münsterplatz. Wenn man da aber aufräumt, dann passiert das nicht mehr, außer eben dass die Nachläufer von Gelenkbussen nicht korrekt erkannt werden von der KI. Und das passiert eben auch auf exakt den gleichen Pfaden und nur mit Gelenkbussen.


    Die invisible Splines an sich sind nicht das Problem, sie verhalten sich wie ganz normale Pfade, nur dass sie das ganze halt sehr unübersichtlich machen und man keine Verkehrsregeln bei den Schnittstellen anwenden kann.


    Edit:


    Übrigens kann man durch anpassung der Pfade noch einiges rausholen und das verhalten der Ki realistischer hinkriegen. Und die Ki kann sehr wohl an ein und der selben Haltestelle die Richtung wechseln, umschildern und Fahrgäste aufnehmen. Der Trick heisst einfach "Profil beargeiten";-) Kleines Beispiel, Sternanschluss bei Linie 6:



    http://i.imgur.com/x43DmjJ.jpg
    http://i.imgur.com/QP1YPr0.jpg

    Viele Grüße,


    wurstbrot

    Edited 2 times, last by wurstbrot ().

  • Ich kann dir zwar net helfen aber für Leute die sich damit auskenne wäre ne LOGFILE gut.