Matrix-Script im Mainzer MAN LC G

  • Moin!


    Ich hab versucht mich zweier Probleme anzunehmen mit der Matrix im Mainzer LC. Zum einen gibt es das Problem dass ein Suffix wie z.B. "E" kaum zu löschen ist nach einmaliger Eingabe und Benutzung (alle übers IBIS oder per Trip zugewiesenen Linien erhalten danach auch ein E als Suffix), zum anderen warum die Fahrplan-KI einfach nicht in der Lage ist ein E als Suffix zu schildern bei zweistelligen Liniennummern + E, bei einstelligen aber schon.


    Das Problem ist dass ich nicht ganz verstehe was hier abläuft, vor allem im Matrix-Macro Teil. Dort wird eine Linienliste und Hof abgefragt. Befindet man sich auf Karte Mainz werden alle nicht gelisteten Linien grundsätzlich wohl nicht geschildert, eine gelistete Linie aber ohne Suffix wenn sie zweistellig ist. Fordert der Trip also "54E" zeigt die Anzeige nur "54". Fordert der Trip "54E01" (also nach Mainzer Muster, gibt es auch nur "54". Was läuft denn hier genau ab und was müsste ich ändern damit die KI mit den Suffixen umgehen kann?


    Das Problem mit dem Löschen des "E" aus dem Suffix bei einer Änderung der Linie auf eine ohne Suffix scheint auch beim Standard-Busfanat-Script zu bestehen.


    Viele Grüße,


    wurstbrot

  • Ich glaube den Fehler gefunden zu haben.


    Ergänze die Matrix.osc wie folgt:



    Es wäre lediglich die Zeile 12 entsprechend einzutragen. Damit wird bei mir "54E" angezeigt, wenn ich "05480" eingebe.


    Ich verwende aber die aktuelle Matrix.osc von Busfanat und habe den Mainz betreffenden Teil nachträglich eingefügt. Die im LC G verwendete Datei ist etwas veraltert.


    Nachtrag: Ich kann auch dreistellige Liniennummern schildern.

  • Deine Änderung in Zeile 12 betrifft aber nur die erste Ziffer. Die Eingabe von "5480" funktioniert natürlich trotzdem bei Dir, da die erste Ziffer als 5, die zweite als 4 dekodiert wird und die 80 als E, und zwar im IBIS- nicht KI-Betrieb. Und im IBIS-Betrieb funktionierte das ganze sowieso, es ging rein um den KI-Betrieb.


    Nachdem ich nun den ganzen Dekodierschmodder auch dem macro vollmatrix-AI-setting zugewiesen habe, macht es die KI manchmal richtig und manchmal falsch. Das gleiche wenn man das Original-Busfanat-Macro einbaut:



    Das ist dann auch näher an der Lösung, aber noch nicht gelöst...

    Viele Grüße,


    wurstbrot

  • Newly created posts will remain inaccessible for others until approved by a moderator.

    The last reply was more than 182 days ago, this thread is most likely obsolete. It is recommended to create a new thread instead.

    The maximum number of attachments: 10
    Maximum File Size: 100 kB
    Allowed extensions: pdf, txt