Support-Thread zum OMSI2-AddOn "Straßenbahn NF6D" / Support thread to OMSI2 addon "Straßenbahn NF6D"

The forum is in reduced operation. The Addon and Support forums remain open.
Please note that OMSI is no longer under development. Some of the developers are now working on a new simulator. Further information concerning the LOTUS-Simulator can be found here.
  • Hallo,
    Ab wann kann man die strassenbahn auf die gleise setzen?Ich habe momentan auf meiner map einen bahnhof mit 2 gleisen die beide c.a. 40-50 m lang sind.Doch wenn ich jetzt versuche die strassenbahn auf die gleise zu setzen,lande ich irgendwo am ende der kachel.


    hoffentlich könnt ihr mir helfen oder einen Tipp geben

    :thumbsup:

  • Könnte mir mal bitte jemand verraten, wie das mit den cti`s funktioniert?
    Habe versucht das mit dem BlinkgeberCP in der .cti "Bochum normal" zu ändern, also ich habe einfach die 0 durch eine 1 ersetzt und die Änderungen gespeichert.
    Bei der ersten Testfahrt jedoch gab es keine Veränderungen. Der Blinktaster leuchtet weiterhin durchgängig.


    Funktioniert das Ganze mal wieder nur im A-Kopf? Ich meine mich nämlich zu erinnern, dass ich im B-Kopf saß.


    Was mich ja desweiteren gewundert hat, so ziemlich alle Einträge in der cti sind auf 0 gesetzt... Ist das so richtig?


    Vielen Dank schonmal für eure Unterstützung

    :D
  • Guten Morgen....seit dem Patch 2.3 tritt nun das Problem mit dem verschwindenden Zug an Weichen plötzlich wieder auf. Also Zug verschwindet, man bleibt an der Weiche hängen, Sound ist noch zu hören. Und das an Weichen die nach den Tipps im Thread und im SDK behandelt worden und wo bis zum Patch auch alle ohne Probleme funktionierte.


    Karte ist meine WIP Ehringen, bis zum Patch war alles i.O., man konnte alle Strecken abfahren ohne das die Bahn weg spawnte.


    Des weiteren ist mir aufgefallen das auch der dynamische Stromabnehmer nicht mehr das macht das er soll. Auf meine Karte gibt es einen Bereich wo die Oberleitung etwas tiefer hängt als Standard. Und sowohl Spieler Zug als auch KI Züge reagieren da nicht mehr drauf seit dem Update.
    Stromabnehmer bleibt stur in der Standard Position stehen.


    Generell bricht mich der Patch langsam an. Seit 2-3 Jahren hatte ich keine Abstürze im Spiel oder Performance Probleme....

    :evil:

    :cursing:


    Wer baut auch an einer Map und hat seit neustem diese Probleme wieder mit Weichen und wer kann das evtl. auf seiner Map mal mit dem Stromabnehmer überprüfen?


    Genervte Grüße.....

    :|
  • Guten Morgen....seit dem Patch 2.3 tritt nun das Problem mit dem verschwindenden Zug an Weichen plötzlich wieder auf. Also Zug verschwindet, man bleibt an der Weiche hängen, Sound ist noch zu hören. Und das an Weichen die nach den Tipps im Thread und im SDK behandelt worden und wo bis zum Patch auch alle ohne Probleme funktionierte. |


    Ich habe das gleiche Problem ?


    Quote

    Zugriffsverletzung bei Adresse 0071FAC2 in Modul 'Omsi.exe'. Lesen von Adresse 00000260: CV.Calculate - J2 (vehicles\Tram_NF6D\NF6D_A.bus)
    Fehler bei Bereichsprüfung: CV.Calculate - J2 (vehicles\Tram_NF6D\NF6D_A.bus)

  • Mit dem aktuellen 2.3 Patch scheint die Funktion der Höhenerkennung für den Pantographen und die Pfaderkennung nicht mehr zu funktionieren. Scheint auch nur explizit für Züge so eingefügt worden zu sein. Weitere Informationen dazu werden hoffentlich demnächst folgen.

  • Ich danke dir für deine Antwort. Das natürlich echt Mist und macht dir natürlich nun auch wieder zusätzlich Arbeit. Hoffe du findest Lösungen zu dem Problemen.


    Schönen Abend

    :)
  • Quote

    Mit dem aktuellen 2.3 Patch scheint die Funktion der Höhenerkennung für
    den Pantographen und die Pfaderkennung nicht mehr zu funktionieren.
    Scheint auch nur explizit für Züge so eingefügt worden zu sein. Weitere
    Informationen dazu werden hoffentlich demnächst folgen.

    Dann wird Kartoffelphantom wohl ähnliche Probleme haben.

  • Das gilt für sämtliche durch User gesteuerte Züge unterschiedlichster Bauart, also auch für den KT4D.


    Das despawnen kann durch fahren im B-Kopf vermieden werden (nur NF6D logischerweise). Auch wenn zur Zeit keine Oberleitung ausgelesen wird, könnt ihr dort außerdem über die Konstante Oberleitungshöhe in der Constfile die dauerhafte Grundstellung des Stromabnehmers festlegen.

  • Den Schalter "Notlösen EEF-Bremse" umlegen (links auf dem Pult mit der Überbrückung Fahrsperre), dann sind es 101,4 km/h statt 72 bei denen abgeriegelt wird. Ist ein kleiner fiktiver Gimmick den ich für Überlandstrecken eingebaut habe.

  • Dafür müsstest du in die jeweiligen Scripte der Fahrmotoren A-kopf.osc und B-Kopf.osc gehen und dort die Werte ändern. Sie befinden sich etwa im Bereich der Zeilen 280 bis 310.

  • Guten Abend,
    Ich wollte fragen ,ob die Fenster bedienbar werden& ob im 2.gelenk die haltewunschtaster geskriptet werden(2.Tür)
    Einen Schönen Abend,
    Felix768

  • Leider wurde der Beitrag von Blue Driver gelöscht. Denn das ist nicht nur ein Problem mit der Map Gladbeck, sondern tritt bei mir auch auf meiner eigenen Karte auf. Daher hätte das hier schon ganz gut hingepasst. Schade schade....


    Aber ich kann bis auf die Logfile den Text von Blue Driver nochmal einstellen. Vlt gibt es noch mehr Leute die dieses Phänomen kennen und vlt gibt es ja eine Lösung dazu. Hier der Fehler von Blue Driver, der auch bei mir so Auftritt. Unabhängig auf welche Map :


    Blue_Driver hat folgenden Text geschrieben:
    ---------------------------------
    Guten Tag,


    ich wollte mal wieder NF6D fahren. Leider habe ich seit der erneuten Installation ein Probelm. Das Spiel stürzt einfach mit einer Zugriffsverletzung ab. Aber nur wenn ich mit der Bahn fahre. Wenn ich mit dem Bus fahre, funktioniert alles. Das spiel stürzt ohne jeglich vorwarnung bei flüssigen 30FPS einfach ab.



    Noch jemand dem das so geht? Jemand der ne Lösung hat?