Trains disappearing when entering rail junctions

The forum is in reduced operation. The Addon and Support forums remain open.
Please note that OMSI is no longer under development. Some of the developers are now working on a new simulator. Further information concerning the LOTUS-Simulator can be found here.
  • Hi!


    I've been trying to construct a tram map for a while now but now, suddenly when testing a new section of the map, everytime I drive onto a dividing junction, the rail vehicle (has been both the NF6D tram and a built-in S-Bahn train) simply disappear when I enter the junction.


    This is not only affecting my own map, as I've experienced the same bug while driving around on the Spandau map, shunting around Spaundau station, when suddently, when I drive onto a dividing juction, the train disappears, but the view camera remains locked in place in driver-view, passenger view and external view (F1, F2 & F3). The game doesn't crash, the train simply disappears.


    It seems like it's always the same junction that has the same issue. In my tram map, I have the same object in use nearby the faulty junction but that one works like it should. AI trams are also affected by this bug, both only occationally. I have tried deleting the junction object and replacing it with a new one, changing the object ID code, but to no avail.


    The issue occurs only when driving in the dividing direction of a juction, not in the merging direction. I did some testing before this issue happened with two bits of track splines, not a junction object, dividing a single pieces of track. I.e., one piece of track spline became two, like a junction but without the object to direct oncoming trains. The results were exactly like this bug, that the trains simply vanished when going in the dividing direction but passing flawlessly when driving in the merging direction.


    Does anyone have a clue as to what's going on here? Any leads would be appreciated.

  • Is no one else experiencing this?


    I can add that this bug only seems to happen to user vehicles, not scheduled AI trains despite what I said earlier. Additionally, when the train disappears, sounds remain from the vehicle until it is deleted, like one deletes a user-driven bus. I.e. the train seems to remain after it has entered the faulty junction but the train models are completely gone and movement and changes in sounds completely stop.


    I have experienced the same issue when constructing a diving junction out of two track splines. My guess is that the game does not know what direction the train is supposed to ge going in and therefore this bug appears, the train gets visibly removedbut remains as an entity.


    I have tried replacing the faulty junction with a confirmed working one, but that didnn't do anything. To me it seems like this but is pinned down to a certain point on the map rather than to a specific object.


    Again, I'm grateful for any responses. This is quite a serious bug since is makes one of my tram routes completely undrivable and there seems to be no solution to it.

  • First of - no responses or acknowledgements from devs whatsoever - I'm getting frustrated of having to figure every single bug out myself in Omsi...


    I believe I've found two solutions to this issue. As such, I'd like to discuss these for future map developers to see


    1. In a custom made junction, the end diversion is too small.

    As mentioned earlier in this thread, which is my best guess for this situation, is that if there is no junction script where two rail paths diverge (nothing that determines continued path), the game does not know where the vehicle is going, and "deletes" it, keeping the entity but locks it in place. In addition, the way path segments are linked together allows for a certain distance between two path ends for them to join up, making 100% precision not necessary. The gap between path segments can be up to around 0.1m, I don't have an exact figure but the point remains that they must be close. If the junction object you are making has a diversion where the path segment ends are too close, the tram will be deleted according to the principe that the game does not know where the train is headed.


    When is this ever an issue? Well, I was making custom tram points for varying turn radii, and to my continues dismay they weren't working properly. The points were to be made as short as possible, which meant that the end diversion of the paths was not big enough. This is likely not the issue you would encouter, though.


    2. Use the other path segment end on the spline or object that links up to the fauilty junction.

    And this is one I just discovered, which is mind-boggling, really. For inexplicable reasons, sometimes a perfectly joined up path segment that ends in a junction that works perfectly elsewhere built according to the same principle (same rotation for both the junction objects and track splines) decides to delete the train as if the spline script wasn't working and the game 'doesn't know where the train is headed'. The solution? Turn around the spline segment (or object) and use the other end. Oddly enough, this seems to have worked for two separate fauily junctions of mine with two different obecjts, one of which being a built-in, default railway junction. Same spline, just turned around.


    I hope this will help whoever ends up in this situation. If anyone else is still experiencing this issue, then please explain your situation and help out with possible solutions. To me, this is one of the worst Omsi editor experiences, where for no reason whatsoever things are not working despite being made correctly.

  • Newly created posts will remain inaccessible for others until approved by a moderator.

    The last reply was more than 182 days ago, this thread is most likely obsolete. It is recommended to create a new thread instead.

    The maximum number of attachments: 10
    Maximum File Size: 100 kB
    Allowed extensions: pdf, txt