OMSI startet nicht mehr nach Windows 10 Update

  • Ich habe mir gerade mein Windows 10 auf die neueste Version geupdatet und jetzt habe ich das Problem,dass ich die Fehlermeldung bekomme,dass der Einsprungpunkt nicht gefunden wurde.


    Ich zitiere:


    Der Prodezureinsprungpunkt "D3D11CreateDevice" wurde in der DLL "C:\WINDOWS\SYSTEM32\inputhost.dll" nicht gefunden


    Diese Meldung habe ich erst seit dem Update.Mit der alten vorherigen Windows Version hatte ich den Fehler nicht.


    Ich habe die Version 1809 17763.1 in 64bit

  • Ja genau,wenn ich auf die OMSI Verknüpfung klicke.Dann kommt von Steam,dass OMSI gestartet wird und kurz danach kommt dann die zitierte Fehlermeldung.Wie gesagt,erst seit dem Update.Komischerweise kann ich aber z.B. ETS 2 oder ATS spielen.Quasi ich spiele im Moment hauptsächlich SCS Software Spiele,weil OMSI ja eben nicht geht

  • DirectX mal neuinstalliert? Kann leider nicht sagen, ob das hilft, da ich (noch) auf 1803 bin.

  • Also an DirectX scheint es wohl nicht zu liegen,da ich natürlich auch schon die Diagnose über dxdiag gemacht habe.Leider lässt sich DirectX auch nicht so einfach neuinstallieren.So weit ich weiß musste SCS auch ein Update bringen,weil sonst ETS und so auch nicht mehr funktioniert hätten.Da muss dann wenn ein Update von Steam oder von Kuhnt selber kommen

  • Hallo,


    für die Leute die in der Windows Version 1809 den Omsi nicht starten können hab ich mal was im Internet gefunden, was bei mir geholfen hat:

    1. Kopiert euch aus dem Ordner C:Windows/System32 die Datei "dxgi.dll"

    2. Und fügt sie in den Omsi 2 Hauptordner ein und ersetzt diese

    3. Es sollte nun Funktionieren

    4. Viel spaß beim fahren :-)


    Gruß Denis8391

  • Hatte bei mir nicht gereicht. Hier noch eine weitere Variante:


    OMSI startet nicht - Einsprungpunkt nicht gefunden