[Editor] Andockfunktion fehlerhaft

  • Hallo zusammen,

    Ich habe nun seit einigen Wochen das Problem, dass die Andockfunktion im Editor (Strg) fehlerhaft ist. Nämlich sind die Splines immer ein paar mm verschoben.

    Mir ist auch aufgefallen, dass es meistens nur bei Splines mit einer 0° bzw. 180° Rotation nicht funktioniert.


    Ich habe in einem anderen Thread gelesen, dass es an einem selbst erstellten Kreuzungs-Objekt liegen könnte. Hab' diese überprüft, aber keinen Fehler (0m langen Pfad) gefunden.

    Auch hab' ich in einem anderen Thread gelesen, dass es an einem Zero-Spline liegen könnte, der auf der Karte verbaut ist. Dort stand auch, dass man im Editor per "Do with whole map..." nach Zero-Splines suchen kann. Hab' aber kein passendes Häckchen gefunden.


    Hat jemand noch eine Idee woran das liegen könnte?


    MfG

    beedle der barde

    Lappi tue d Augä (n) uuf.

  • Ich kann den Effekt bestätigen. Das passiert im Kreuzungseditor, aber auch im Karteneditor selbst, wobei man bei letztem ja selten Splines genau in Nord-Süd-Richtung verlegt. Dafür gibt es wohl keinen speziellen Grund bzw. Auslöser.

    Payware-Addon "Berlin X10" ist fertig.


    Als Download-Version, Box-Version, Special-Edition und bei Steam erhältlich.

  • Dafür gibt es wohl keinen speziellen Grund bzw. Auslöser.

    Also kann man auch nichts dagegen machen?


    Das passiert im Kreuzungseditor, aber auch im Karteneditor selbst

    Das mit dem Kreuzungseditor ist bei mir schon immer so, beim Karteneditor hat's erst vor ein paar Wochen angefangen.

    Aber beim Kreuzungseditor wird einfach der neu angelegte Pfad um 0.02° verschoben. Beim Karteneditor ist es nicht nur die Rotation (siehe Bild).




    Bei den invis_streets ist es an sich nicht so schlimm, da die Autos weiterfahren. Aber beim Gehwegen oder Strassen sieht's dann einfach doof aus. Und es wird halt allgemein nicht so genau.

    Lappi tue d Augä (n) uuf.

  • Beim Kreuzungseditor ist auch nicht nur Rotation, sondern (spätestens nach mehreren Pfaden) auch eine Verschiebung. Im Map-Editor ist sie gleich größer, weil die Elemente länger sind und die paar Grad eine größere seitliche Verschiebung ausmachen. Im Forum hat noch niemand ein Mittel dagegen.

    Payware-Addon "Berlin X10" ist fertig.


    Als Download-Version, Box-Version, Special-Edition und bei Steam erhältlich.

  • Kann es sein dass das was mit Gleitkommazahlen zu tun hat?


    Das Öroblem habe ich meistens bei Längeren Splines.

    Lösung: Statt eine 100m-Spline zu bauen und dort anzudocken, z.B. eine 99m-Spline und dann direkt mit N eine 1m Spline dran, an diese dann Andocken.

    SWÄG...8o

    Aktuell: Projekt Lörrach/Dreiländereck - SWEG-Repaints

  • eine 99m-Spline und dann direkt mit N eine 1m

    Ne, die Splines sind kürzer. So 20-60m (meistens)

    Auch bei 60m kanns Vorkommen, aber ic habe das Gefühl je länger die gerade, desto stärker die Verschiebung. Ich würds mal mit ner 59m-1m Probieren, sobald das angedockt ist kannst du die 1m-Spline auch wieder löschen und die andere auf 60 verlängern.

    SWÄG...8o

    Aktuell: Projekt Lörrach/Dreiländereck - SWEG-Repaints

  • Newly created posts will remain inaccessible for others until approved by a moderator.

    The maximum number of attachments: 10
    Maximum File Size: 100 kB
    Allowed extensions: pdf, txt