Gelenkphysik nach Modding fehlerhaft

  • Hallo Zusammen,

    ich habe den Citaro FL G mit einigen Mods (Matrix, Drucker, Sitze) ausgerüstet, seitdem habe ich jedoch ein Problem mit der Gelenkphysik (s.u.).

    Die Logfile habe ich bereits analysiert, die sagt nichts dazu passendes.

    Folgende Dateien habe ich bereits mit den Originaldateien verglchen, um zu versichern dass der Fehler nicht dort liegt (Der originalbus hat keinen derartigen Fehler):


    Bus-Dateien:

    -Mod-Bus nutzt gleiche Articulation-scripts

    -Geometrische Grunddaten ect. sind bis auf den Dateipfad des Nachläufers identisch


    Model.cfg:

    -ganz am anfang der Model.CFG befinden sich Einträge zum Gelenk, diese sind ebanfalls überprüft.


    Gibt es noch eine andere Datei o.ä., die Einfluss auf die Gelenkphysik hat?



    Danke schonmal für Hilfe,

    LG Niklas

    SWÄG...8o

    Aktuell: Projekt Lörrach/Dreiländereck - SWEG-Repaints

  • Mit dem Gelenk Script hat das nichts zutun, das wird innerhalb des Scripts nämlich von OMSI selbst berechnet.


    Und du bist ganz sicher das du nicht zufällig mal das Gelenk Modell getauscht hast? Für mich sieht das nicht wie das originale Alterr Gelenk aus. Kann mich da aber auch täuschen.


    Liegt denn die Animation im Modell File noch auf den Gelenk Dummys.


    Jedenfalls sieht das Gelenk starr aus, das kann darauf deuten das es mal neu exportiert worden ist und dabei sind dann die Bones verloren gegangen. Ohne Bones ist das Gelenk ein starres Objekt und aktuell sieht das einfach starr aus.

    :xbus_small: ADMIN-Team & BETA-Test: FreD's Mods


    "Tut das Not, dass das hier so rumoxidiert?"

  • Model.cfg:

    -ganz am anfang der Model.CFG befinden sich Einträge zum Gelenk, diese sind ebanfalls überprüft.


    Schau mal bitte in der .bus-Datei vom Vorderwagen, ob im Abschnitt [script] die Anzahl der aufzurufenden Scripte mit der Zahl in der ersten Zeile übereinstimmt. Das Articulation-Script steht normalerweise an vorletzter Stelle, wenn Du da vorher noch z.B. zwei andere Scripte eingefügt hast, ohne die Zahl zu ändern, wird es nicht aufgerufen.

  • Danke für eure Tipps!


    setra315_HAV

    nein, das Gelenk ist das Originale, es sind sogar exakt die identischen Dateien wie beim funktionierenden, ungemoddeten FL G. Werden die Bones in der Model.cfg definiert? Wenn ja, unter Welchem Befehl finden sich diese?


    e2h1986

    Das war auch mein erster Verdacht, die Zahlen Stimmen aber überein.


    Problem bleibt also.

    LG Niklas

    SWÄG...8o

    Aktuell: Projekt Lörrach/Dreiländereck - SWEG-Repaints

  • Wenn du am Gelenk nichts geändert hast, und auch sonst niemand was dran gemacht hat dann sind die Bones Korrekt.


    Die Bones gehen verloren, wenn du das Modell nach Blender importierst und exportierst.

    Bones sind nur Blender/3D-Programm-Spezifisch. Hat nichts mit irgendwelchen Einträgen zutun.

    :xbus_small: ADMIN-Team & BETA-Test: FreD's Mods


    "Tut das Not, dass das hier so rumoxidiert?"

  • Newly created posts will remain inaccessible for others until approved by a moderator.

    The maximum number of attachments: 10
    Maximum File Size: 100 kB
    Allowed extensions: pdf, txt