MAN DN 95 schwarze Texturen

The forum is in reduced operation. The Addon and Support forums remain open.
Please note that OMSI is no longer under development. Some of the developers are now working on a new simulator. Further information concerning the LOTUS-Simulator can be found here.
  • Hallo,


    ich habe mir heute den MAN DN 95 gekauft und habe leider das Problem mit schwarzen Außentexturen.

    Lade ich z.B. dass Addon Berlin X10 und wähle diesen Bus aus , wird dieser bereits mit schwarzen Texturen im Auswahlmenü dargestellt.

    Ist er dann auf der Karte plaziert , sind bereits die Außentexturen schwarz , nur beim heran zoomen kommt die gelbe Texture zum erscheinen , zoomt man wieder weg , wird der Bus von außen schwarz.

    Es sei aber gesagt , dass mir das auf der Karte Grundorf noch nicht passiert ist , da wird der Bus ohne diese Probleme geladen.

    Der 4GB Patch ist installiert , auch die Einstellungen runter zu stellen , brachte mir beim X10 Addon nichts.

    Solche Probleme kenne ich aber auch vom Hamburger Buspacket.


    Kann das nun an den Texturen liegen , wenn ja kann man bitte Low Texturen nachreichen.


    Vieleicht haben auch die Nvidia Karten (GTX1080Ti ASUS) ein Problem mit alten 32bit Anwendungen.


    Ich denke meist .dass die Hardware meines PC nicht richtig funktioniert , spiele ich aber andere Spiele ,auch aktuelle , bekomme ich aber auch keine Abstürze,Freeze oder halt wie in dem Fall , dass Texturen von Anfang an schwarz sind oder nach einer Weile werden.


    Das kann dann doch nur an OMSI oder an den verwendeten Texturen liegen , dass diese dann am Arbeitsspeicher kratzen oder das Textureformat für OMSI schlecht ist.


    Wäre nett wenn man das nochmal kontrollieren würde oder abgeänderte Texturen nachreichen würde , da ja der Bus ja so wirklich gut gelungen ist.


    mfg

  • Moin Moin,


    hat denn niemand das Problem mit dem Bus , dass Texturen schwarz sind , bereits schon im Auswahlmenü.

    Es betrifft ja nicht nur das Außenmodell , auch im Innenraum verliert der Bus die Textur am Lenkrad und den Fußpedalen.

    Auch da erscheinen die Texturen nur beim heran zoomen.


    Ich verstehe auch seitens der Entwickler oder dem Entwickler nicht ,warum man da nicht Texturen nachreichen kann , die dieses Problem beseitigen.


    Mir ist schon bewusst , dass da OMSI und Addons und Einstellungen , die Probleme erhöhen.

    Es ist doch aber sehr verwunderlich , wenn z.B. die Karte Berlin X10 geladen wird , dass alle Busse korrekt im Auswahlmenü angezeigt werden , aber nur dieser bereits schwarze Texturen hat.


    Hier kann es doch nur an den verwendeten Texturen liegen.


    Ich schließe ein Speicherproblem aus ,auch dass ein Fehler meiner Grafikkarte dies verursacht , wenn ich z.B. GTA V über Stunden spielen kann.


    mfg

  • Quote

    Ich schließe ein Speicherproblem aus ,auch dass ein Fehler meiner Grafikkarte dies verursacht , wenn ich z.B. GTA V über Stunden spielen kann.


    Die Aussage ist total irrelevant für OMSI. Du kannst auch eine Grafikkarte mit 32 GB Speicher haben und hast dennoch schwarze Texturen, weil bei OMSI so gut wie alles über den Prozessor läuft. Dir bleibt definitiv nichts anderes übrig, als Einstellungen reduzieren.

    Zeig halt auch einfach mal deine Einstellungen, sonst kann dir eh keiner helfen. :)

    :xbus_small: ADMIN-Team & BETA-Test: FreD's Mods


    "Tut das Not, dass das hier so rumoxidiert?"

  • Doch, hatte ich auf Berlin X10. Ist wohl ein Problem mit dem Arbeitsspeicher oder der Rechnerleistung. Man darf nicht vergessen, dass OMSI alt ist.


    Denn ich kann z.B. Zusi3 oder Train Simulator in höchster Grafikoption flüssig spielen, wohingegen OMSI rumzickt, ruckelt und spackt.


    Soweit ich das verstanden habe, geht OMSI eher auf Prozessor, wohingegen moderne Games auf GraKa gehen.

  • Grüße Euch,


    erstmal danke für Euer Feedback.



    Meine OMSI Einstellung im Game:


    -Bild 1-6


    Grafikkarte Nvidia Systemsteuerung ( OMSI.exe)


    -Bild 7-10


    Nvidia Treiber ist der 441.87 , aber auch mit älteren Treibern besteht das gleiiche Problem.


    Zu meinen System:

    ASUS i7-8700 K

    ASUS Nvidia GTX1080Ti

    16GB RAM

    WIN 10 64bit

    WIN 10 ist auf SSD

    OMSI auf HDD


    Ich bin immer noch der Ansicht , dass entweder die Kombination der Texturen in den Format für OMSI ungünstig sind oder deren Größe.

    Ich lade am Bsp. X10 Addon meine Einstellungen und da ist der MAN NL NG und der MAN DL 05 ohne Texturverluste oder schwarze Texturen.

    Beim DL 05 hat eine Textur 5,33 MB im .dds Format , bei den Reklame Texturen des MAN DN 95 beträgt deren Größe 48MB im .bmp Format.


    Wie ich schon erwähnt , dass gleiche passiert auch beim Hamburger Buspaket , warum kann man nicht den Kunden Texturen in anderen Formaten nachreichen , was bringen 4K Texturen , wenn OMSI schon so immer am Arbeitsspeicher kratzt und der 4GB Patch irgendwann keinen Sinn mehr bringt.


    mfg

  • Wie realistisch ist es, dass 1000 Fahrzeuge (mit Fahrplan (z.B. Bus oder Zug)) auf einer Kachel rum fahren? Es ist eigentlich absolut nicht realistisch.

    Die Einstellungen für den KI-Verkehr beziehen sich immer auf die aktuelle Kachel. Sofern dann die Priorität des Fahrplans noch auf 4 gestellt ist, dann hast du zwar wundervollen KI-Verkehr aber es schlägt sich einfach auf deine Leistung nieder. Jedes dieser Fahrzeuge muss trotzdem geladen werden, und jede Textur wird in den Speicher geprügelt.


    Auf Karten wie Grundorf kannst du das gerne machen, aber bei X10 solltest du dein Glück nicht herausfordern.


    Genau so ist es nicht sinnvoll alle Elemente auf der Karte zu laden, weil die Elemente auf deinem Fahrweg sowieso geladen werden. Braucht man da den Namen eines Ortes, auf einem Schild, in irgendeiner Seitenstraße, die du so wieso nicht anfahren wirst?

    Auch hier darfst du wieder nicht vergessen: Jedes Objekt hat eine Textur und dieser wird ebenfalls in den Speicher geprügelt.


    Reduziere mal die Einstellungen alle und schaue ob es dann geht, ich vermute mal schon.

    :xbus_small: ADMIN-Team & BETA-Test: FreD's Mods


    "Tut das Not, dass das hier so rumoxidiert?"

  • Moin Moin,


    so habe mal bissel an den Einstellungen rum geschraubt , eine Besserung habe ich erreicht ,

    Was hast du denn so eingetellt , besonders bei den genannten Punkten.

    Bei der Einstellung Max.Speicherbedarf bin ich mir nicht so ganz sicher , was da das richtige ist.

    Ob diese Einstellung nun für den Arbeitsspeicher verwendet wird oder ein Bezug zur Grafikkarte hat.

    Würdest du an meinen Nvidia Systemsteuerungseinstellungen was anders einstellen.

    Trotzdem bin ich immer noch der Meinung , dass man Texturen verwenden sollte , die nicht OMSI so beeinflussen.

    Andere Payware oder Freeware Busse bereiten ja auch keine Probleme und können sogar als KI Busse eingesetzt werden.

    Am Beispiel dieses Busses , sieht man ja die Auswirkung , dass es sich negativ auf die Performance auswirkt.


    mfg

  • Das liegt aber nicht unbedingt am Bus, eher an deine Einstellungen und die üblichen OMSI Macken. Ich kann den DN95 ohne Probleme auf X10 fahren und diesen dort auch als KI Verkehr nutzen.

  • busfan-07

    Andere Texturen gibt's nicht. Es gibt nur Texturen mit niedriger Auflösung, und dann hast du das Problem das die Texturen Pixel haben und teilweise auch schwere Artefakte im Bild. Willst du das wirklich haben, für ein Produkt wofür du Geld bezahlt hast? Ich denke nicht, das sieht dann aus wie ein DOS Spiel in Mitten der wilden 90er Jahre.


    Im Umgebungsverkehr verwende ich:

    21 - mit Fahrplan (z.B. Busse)

    2 - für die Fahrplanpriorität


    Und für den Texturspeicher habe ich 1024 MB angegeben obwohl ich eine 4096 MB GPU habe.

    Meine Echtzeittexturen sind auf 256 MB begrenzt.


    Hab auf keiner Karte Probleme damit und auch keine schwarzen Texturen. Ich hab X10 mit meinen Settings getestet und auch dem DN95 und habe keine Probleme mit irgendwas. Ab und an hängt es etwas aber das ist ja nichts neues bei OMSI.


    Echtzeittexturen müssen nicht unbedingt so hoch sein, das sind in der Theorie glaub nur Spiegel. Und die Gefahr das die Textur Pixel zeigt ist wirklich sehr gering. Außerdem ist das Dauerrendern bei den Spiegeln teilweise abgestellt.


    Bei nVidia kann ich dir nicht helfen. Hab eine AMD Karte.

    :xbus_small: ADMIN-Team & BETA-Test: FreD's Mods


    "Tut das Not, dass das hier so rumoxidiert?"

  • Danke für die vielen Tipps.


    Naja das verändern des Wertes Max.Speicherbedarf auf 6000.0 MB mit meinen Einstellungen wie oben angegeben , brachte wirklich etwas , der Bus wurde diesmal im Auswahlmenü ,sowie auch beim Laden mit Texturen dargestellt.

    Eine Proberunde der Linie X10 war flüssig und ohne Einbrüche ,nur bei der Rücktour fingen einige Texturen der Straßen und Laternen an schwarz zu werden.

    Aber da kann ich ja noch die Tipps hier verwenden.

    Setra ich gebe dir ja Recht ,aber wiegesagt andere Busse ob nun Pay oder Freeware , bereiten auch keine Probleme und da fiel mir auf ,dass die meisten .dds Formate haben , wo wahrscheinlich OMSI keine Probleme hat.


    mfg

  • Aktiv Probleme macht beinah nur das PNG Format, alle anderen Formate kann man Bedenkenlos verwenden. Es kommt auch nicht auf das Format an sich an. Der Speicher läuft nur anhand der Speichergröße voll, nicht anhand des File Formats. Die Texturen im DN95 haben eine erhöhte File Size, das ist wahr. Tweak einfach noch ein bisschen an den Einstellungen rum, dann wird das schon.

    :xbus_small: ADMIN-Team & BETA-Test: FreD's Mods


    "Tut das Not, dass das hier so rumoxidiert?"

  • Ja das werde ich mal noch weiter testen , hoffe aber das seitens des Entwicklers alternative Texturen angeboten werden , die sich nicht so auf die Performance auswirken.

    Leider habe ich da keine Ahnnug , wie man selber die Texturen verändern kann , in ein anderes Format oder so abändern , dass sie weniger die Performance beeinflussen.

    Den Bus als KI Bus auf Karten einsetzen ,wäre wohl nicht sehr sinnvoll mit den derart jetzigen Texturen.

    Ehrlich gesagt finde ich es auch nicht sehr schön , ständig die Einstellungen so herunter zu schrauben , dann verliert OMSI irgendwann seinen Reiz.

    Warum Erbauer dies teilweise ignorieren ,kann ich nicht nachvollziehen , wenn es bekannt ist ,dass OMSI so negativ reagieren kann.


    Danke nochmals für den Tipps.


    mfg