Editor - Ältere Speicherstände laden bzw. Objekte und Splines wiederherstellen?

The forum is in reduced operation. The Addon and Support forums remain open.
Please note that OMSI is no longer under development. Some of the developers are now working on a new simulator. Further information concerning the LOTUS-Simulator can be found here.
  • 1. Welche Version von OMSI 1 oder OMSI 2 wird benutzt?

    OMSI 2


    2. Wie häufig tritt das Problem auf und in welcher Form? (Fehlermeldung, aber weiter spielbar / Absturz / Freeze / ...)

    Editor-Start bzw. Objekte o. ä. platzieren, aber weiter bewegbar


    3. Welche Tätigkeit/Aktion führt zu dem Problem? (Neuen Bus platzieren / Fahren mit Fahrplan /...)

    Editor starten bzw. Map *ge*laden


    4. Welcher Content wurde verwendet? (Karte, Busse, ...)

    private Map "Lienental"


    5. Welche Mods oder Plugins werden verwendet? (SweetFX, ...)

    keine


    6. Logfile im Spoiler oder Anhang.



    7. Systemdaten (Betriebssystem, RAM, CPU, ...)

    Prozessor: Intel Core i7-8700 CPU @ 3.20 GHz 3.19 GHz

    Grafikkarte: nVidea GeForce GTX 2070

    RAM: 16 GB

    Betriebssystem: 64 bit

    Windows: Windows 10 Home


    Hallo liebes OMSI-Forum,:)


    seit einiger Zeit sind mir wieder den Editor bzw. meine private Map ans Herz gewachsen. Nur habe ich vorhin ein Problem entdeckt: Als ich mir eine neue Textur in den Terrain-Kram gepackt habe, muss man ja immer auf allen Kacheln die Textur einmal "wegradieren". War alles normal bis ich dann an einer Straße ankam und Texturen auf den Boden gemalt, BUS-Spuren und Parkmakierungen nicht auf den Straße (ebenfalls auf dem Gras) sah. Naja, dann habe ich eben die Straßen wieder neu gelegt (20min..X/) und musste dann ja den Timetable wieder anpassen, da die Straßen ja entfernt waren. Dann "fuhr" ich die Straße lang bis ich an einem Punkt ankam, der nicht zu der Linie gehört.. Ich sah: einen fehlenden Hauptbahnhof + die komplette Straße, Kreuzung und angrenzende Straßen. Von da an habe ich den Editor geschlossen und mich ins OMSI-Forum bewegt.


    Ich hoffe, dass man irgendwie alte Speicherstände nochmal laden kann bzw. Objekte (Crossings, Haltestellendächer, Grünzeug etc. ) irgendwie wiederherstellen kann.


    LG, Superfahrer?(

  • MarvinK

    Approved the thread.
  • "Zurückgehen" kannst du natürlich nur, wenn du vorher Sicherungen der Map angelegt hast.

    Aber tröste dich, du bist nicht der einzige, der viel Zeit damit verbracht hat, Zerschossenes wiederherzustellen...

    Terraintexturen sollte man generell nicht direkt im Editor kreiren, sondern in der global.cfg.


    Viel Spass :)

    Freundliche Grüsse Hans Niemeyer

  • Hey,


    sorry, dass ich jetzt erst antworte :c. Meinst du mit Sicherungen, dass ich, sobald ich am Tag fertig war, die Veränderungen abgespeichert habe? Falls das so ist - wie geht das dann? ;)


    Das mit dem "seit einiger Zeit" war nicht böse gemeint.. (hehe):)


    Vielen Dank im Voraus, Superfahrer!^^

  • ich denke, er meint damit Kopien vom ganzen Mapordner in anderen Speicherorten, um eine zerschossene Map eventuell wieder mit einer funktionierenden Version ersetzen zu können. Ich habe für sowas z. B. einen Ordner in den Dokumenten, wo ich vorher die betreffenden Dateien / Ordner hinkopiere, der grade bei kritischen Modifikationen eine Sicherheit bietet, wenn was schief geht.


    Niemand nimmt uns OMSI weg

    Bin jetzt in der Webdisk zu finden https://reboot.omsi-webdisk.de/

  • Das ist eigentlich ganz einfach: alle Veränderungen, die du an deiner Map machst, werden in dem jeweiligen Map-Ordner abgespeichert. Diesen findest du in deinem Omsi-Verzeichnis unter "maps". Erstelle einen Backup-Ordner, am besten auf einer anderen Festplatte oder Partition, und lege deine Map dort ab.


    Bei Bedarf dann in umgekehrter Richtung, erspart Kummer, Tränen und Zeit ;)


    Ach so: es gibt ein gut gemachtes Backup-Script, kannst du HIER herunterladen

    Freundliche Grüsse Hans Niemeyer

    Edited once, last by H.Niemeyer ().

  • Hey ihr beiden,


    das Backup-Script habe ich mir runtergeladen und - wie es installiert werden soll - installiert.


    Ok, ich werde mir dann auch einen Ordner anlegen. Mal schauen, wo ich den hinpacke ;)


    LG, Superfahrer