Posts by Trollforce

Scheduled maintenance pending. The forum will be closed at 4 o'clock a.m.

    Hat mittlerweile irgendwer schon was zu dem "Could not lock light map of tile 0 for getting ambient light for objects!"-Fehler was rausgefunden?
    Ich bin seit einer Woche dran, nichts. Gar nichts. Es wäre schön wenn Marcel und Rüdiger Zeitnah mal wieder ein Statement zu diesem Fehler oder zum Status des Patches allgemein machen könnten....

    Das könnte dann auch erklären, warum bei vielen die Fehlermeldung "{endif} ist kein gültiger Gleitkommawert" auftritt. Sieht fast so aus als wäre irgendeine If-Abfrage nicht abgeschlossen. Aber dann würde der Fehler ja auch in OMSI1 auftreten. Ich vermute fast, das M+R irgendwas am Scriptinterpreterer geändert haben.


    Seeadler, ich hoffe du hast mehr Erfolg als ich.


    Weiterhin besteht das Problem mit den "Could not lock light map"-Fehler. Hab alles ausprobiert, Lightmaps-BMPs alle nochmal überspeichert mit unterschiedlichen Einstellungen, die Lightmaps gelöscht etc.
    Was mich etwas irritiert, was und oder wieso möchte OMSI die Lightmaps locken?

    Mal ne zusammenfassung meines gesammelten Know How's zum Thema OMSI1 Karten in OMSI2 integieren.


    "Zu wenig Arbeitsspeicher" - Fehler
    Passiert dann wenn OMSI beim Laden der Karte aufgrund eines Errors beim Laden einer oder mehrere Tile-Dateien in eine Endlosschleife gerät. Ab einer gewissen Zeit wird dann die magische 2GB - Ram Grenze überschritten und so tritt der Fehler auf. Siehe Logfile.txt im OMSI Hauptverzeichnis. Sieht dann z.B. so aus:


    Quote

    [.... endlos ....]
    304 14:58:00 - - Error: In map file "maps\_MAPNAME_\tile_-3_2.map" there was an error in line 493!
    305 14:58:00 - - Error: In map file "maps\_MAPNAME_\tile_-3_2.map" there was an error in line 493!
    306 14:58:00 - - Error: In map file "maps\_MAPNAME_\tile_-3_2.map" there was an error in line 493!
    [.... endlos ....]


    "There was an error in line xxx"


    Deutet oft auf fehlende Dateien hin, ggf. aber auch auf (noch) inkompatible Objekte und Splines.
    Es handelt sich m.E. nicht um die betreffende Zeile, sondern vielmehr um den Objekt bzw. Spline-Codeblock davor, also dem Objekt/Spline welches unmittelbar davor definiert wurde.


    Was mir aufgefallen ist, das ein Mod welcher auf vielen Karten sehr beliebt ist derzeit komplett die Dienst unter OMSI2 verweigert, welches dann diesen Fehler beim Laden der Karte reproduziert.
    Und zwar steht das gcw-Addon im Verdacht bei mir, den Einsatz sämtlicher OMSI1-Karten die diese Objekte verwenden zum Absturz zu bringen. Alle Fehler die ich habe, finden sich in Codeblöcken
    in denen ich ein- oder mehrere Objekte aus dem Mod entnommen habe.


    Meine Vermutung ist das die Scriptdateien, welche im gcw-Addon Ordner eingebunden sind, OMSI2 einen Strich durch die Rechnung machen. Ich werde das mal weiter Prüfen.
    Konkret sind das die Scripts, die das Aufblinken ("flashen") der Leuchten ermöglichen.


    Hoffe ich konnte dem ein oder anderen ansatzweise helfen.

    What a phenomenal masterpiece! It's absolute awesome! Thank you for that great work..!!
    I've donated you something.


    Ein phänomenal toller Bus! Absolut umwerfend, ich habe ihm einen kleinen Betrag gespendet, in der Hoffnung das noch viele weitere großartige Busse von ihm kommen. Jeder sollte sich überlegen den ein oder anderen Euro an solch guten Busbauer zu spenden um dauerhaft die Motivation bei den Busbauern für qualitativen Nachschub zu sichern anstatt immer nur rumzuflamen :) Er hats sichs wirklich verdient!

    Moin zusammen!


    Ich möchte meine Umläufe gerne übers Notepad editieren, da mir das etwas flexibler erscheint was die Reihenfolge der einzelnen Fahrten angeht. Ich baue gerade ganze Dienste zusammen auf den jeweiligen Umläufen (sowie es bei mir zuhause in Real auch üblich ist), jetzt kam eine Linie dazu, sodass ich jetzt natürlich das Problem habe Fahrten "dazwischen schieben" zu müssen.


    edit: Hab die Lösung gefunden, die letzte Zeile beschreibt jeweils die Minute am Tage!


    Ansich alles kein Problem, die Zeilen erklären sich recht einfach:



    Hat jemand vielleicht eine Ahnung was die letzte Zeile jeweils bedeutet? Wäre Super! :)

    Seit neustem habe ich auf einer Kachel auf meiner Map ein Problem, welches ich mir beim besten Willen nicht rekonstruieren kann.


    Jedes mal wenn ich ein neues Objekt oder Spline platzieren will, generiert mir OMSI immer äußert ungewöhnliche Koordinaten, z.B. geht er bei der Höhe des Objektes ins unendliche (siehe Screenshot).



    Interessant ist, das ich den Fehler nur auf bestimmten Kacheln hab. Jemand ne' Idee?

    Seit geraumer Zeit bastele ich eine Just 4 Fun Map für mich die mittlerweile auf über hundert Kacheln (basierend auf Map Pilzdorf) angestiegen ist.


    Doch seit neustem macht der Editor äußert seltsame Probleme:


    - Auf einigen Kacheln kann ich keine Objekte und Spline mehr platzieren, da die Höhe stets ins Unendliche steigt (hier: 3.402824E38m)
    - Wenn ich Objekte platzieren will die der Editor oft ganz woanders hinpackt
    - Und das schlimmste von allen: Die Fahrgäste finden an einigen Haltestellen den Weg zum Bus nicht mehr. Sie laufen zwar fröhlich Wild in alle Richtungen los wenn der Bus anhält, können aber nicht einsteigen. Sind also etwas desorientiert.


    Hat jemand schon mal was ähnliches gehabt? Irgendwie beschleicht mich das Gefühl das OMSI aus irgendeinem Grund ein Problem hat die Koordinaten zu berechnen..


    Moin Moin,


    Ich hab nen kleines Problem bei meinem aktuellen Kartenprojekt. Und zwar habe ich eine Landstraße (8m Breite) und verwende die Junction Altonaer Straße. Und zwar hab ich da jetzt folgendes Problem, wenn Autos in die Nebenstraße abbiegen wollen bremsen sie von ca. 70 kmh runter teilweise auf 5 kmh, und tragen ihr Auto um die Kurve herum sodass jeder normale Verkehrsteilnehmer welcher hinter dem besagten Wagen fährt graue Haare bekommt und schimpft wie der Dicke aus OMSI.


    Gibts eine möglichkeit die Abbiegegeschwindigkeiten irgendwie anzupassen? Normalerweise kämen die Autos zumindest realistisch mit 30 kmh um die Kurve herum.


    Vielen Dank euch schon mal!

    Das ist ja auch gar nicht das problem :) Der Bus läuft einwandfrei (selbst neben dem geleakten! Unterschiedliche Ordnerstrukturen).


    Es geht nur darum das seit der geleakten Version, nach der Meinung von ein paar Usern einige Verschlimmbesserungen vorgenommen wurden.


    Versteht mich bitte nicht falsch, der Bus ansich ist spitze und das möchte ich auf keine Fall in Frage stellen! Ich freu mich trotzdem auf die Veränderungen seitens der Community.

    Ich finds Super, das du all' diese Änderungen (auch mit der Kasse etc.) in den geleakten Lions City eingebaut hast. Nachdem du das mehrmals hier im Thread betont hast, bitte erlöse mich von meiner Neugier: Wirst du uns auch aufzeigen per Tutorial o.ä., wie wir z.B. eine Kasse in den Lions City bekommen?


    Das wäre genial!

    Hallo zusammen,


    Ich hab gerade mal eben die 10-Seiten Threads hier überflogen, und habe offensichtlich keine Lösung zu meinen Problem gefunden.


    Es ist ja bekannt, das dass "festmachen" von Objekten, wie z.B. Laternen (so auch in der SDK beschrieben), etwas "tricky" ist. Das heisst oft sind Objekte Kilometerweit verschobenen und lassen sich nicht an die gewünschte Stelle platzieren oder sind gar nicht sichtbar. Mir raubt das so langsam den letzten Nerv :D


    Gibt es irgendwelche Tricks oder Herangehensweisen um Straßenlaternen, nervenschonend in regelmäßigen Abstand an einen Spline zu befestigen?


    Ich freue mich auf eure Meinungen und Ratschläge!