Posts by Shiju27

The forum is in reduced operation. The Addon and Support forums remain open.
Please note that OMSI is no longer under development. Some of the developers are now working on a new simulator. Further information concerning the LOTUS-Simulator can be found here.

    Es dürfte an Folgendes liegen:

    Quote

    93 19:14:27 - - Warning: Did not find texture file "yf004.png"!
    94 19:14:27 - - Warning: Did not find texture file "yf001.png"!
    102 19:14:33 - - Warning: Did not find texture file "IMG_0238_3.jpg"!
    ... bis ...
    140 19:14:33 - - Warning: Did not find texture file "IMG_0238_3.jpg"!

    Ich weiß nicht, wozu genau diese Dateien gehören, aber entweder fehlen diese Dateien oder liegen an einem falschen Ort.


    Am besten nochmal die Mods durchgehen (Readmes) und schauen, ob du nicht doch etwas vergessen hast.




    Deweiteren:


    72 19:14:22 - - Error: The file "Money\gcW_Euro\euro.cfg" could not be loaded! <- Da fehlt wohl die Euro-Mod


    Diverse Error (Einträge 157-355) mit Hinweis auf fehlende .ovh-Dateien aus dem Hamburg-Addon (?) <- Entweder Hamburg-Addon aktivieren oder die AI-List bearbeiten (wenn es KI-Fahrzeuge sind und keine StaticVehicles)


    Die letzten beiden sollten an sich nicht die Optik verändern, aber dies zu beheben, sollte dennoch nicht verkehrt sein

    ;)




    Ich hoffe, ich konnte helfen

    :)

    Schau mal am besten folgendes nach:


    Sind in der jeweiligen .cti-Datei die Repaints auch so benannt, wie in der AI-List?

    Wenn du die cti-Datei mittels eines Editor-Programms (ich empfehle Notepad++, der Windows-Editor geht aber auch) öffnest, findest du z.B. Folgendes:



    Es geht dabei um die Zeile unter [item], dieser Name muss in der AI-List stehen (im Beispiel BOGESTRA), auch auf Groß- bzw. Kleinschreibung, Leerzeichen und Sonderzeichen achten.
    U.U. kommt OMSI aber nicht mit Umlauten bzw. Sonderzeichen klar.


    In diesem Fall in den Dateien (.cti und Ai-List) die Umlaute und Sonderzeichen entfernen bzw abändern:
    ä -> ae; ß -> ss usw.
    Ich selbst nutze im Notepad++ die Kodierung auf ANSI (Menüleiste Kodierung -> ANSI, danach Dateien abspeichern). Anschließend nochmal in den Dateien schauen, ob sich nicht auch eines der (Sonder)Zeichen geändert hat, notfalls abändern.



    Sind die entsprechenden Repaints auch im richtigen Ordner?

    In der jeweiligen .cti-Datei gibt es unter Umständen auch Verweise zu Unterordnern.
    Dann entweder einen entsprechenden Unterordner erstellen und die Dateien (.jpg, .tga o.ä., NICHT die .cti-Datei) dorthin verschieben
    ODER in der .cti-Datei den Unterordner "entfernen".


    Im oberen Beispiel müsste ein Unterordner "Vestische" im Ordner Werbung erstellt werden und die Datei "Bogestra.dds" dorthinein geschoben/kopiert werden ODER in der .cti-Datei "Vestische\" gelöscht werden.
    Die anderen beiden Dateien "04_Bogestra.dds" und "05_KoeR.png" bleiben im Hauptordner und müssen nicht verschoben werden.



    Ich hoffe, ich konnte helfen

    :)



    Wenn du außerhalb des Editors die Liniennummer (und eventuell Ziel) ändern möchtest, musst du dir die .ttp-Dateien vorknöpfen.
    In der .ttp-Datei gibt es zum Beispiel folgende Angaben:



    [trip]


    Reimerweg
    137


    Die erste Zeile unter [trip] hat keine Relevanz und muss nicht benannt werden.
    Die zweite Zeile weist das Ziel des Trips zu. Der Name muss in der entsprechenden Hofliste vorhanden sein, damit das Ziel geschildert wird.
    Die dritte Zeile gibt die Liniennummer vor, die zum Einen als Linie geschildert wird, zum Anderen aber auch die Steckschilder ansteuert, sofern welche vorhanden sind (siehe Hof-Datei). Eine entsprechend benannte jpg-Datei muss aber auch im Ordner (von der Hof-Datei vorgegeben) vorhanden sein.


    Weiteres kannst du hier nachschauen

    ;)

    Schau mal hier: Die neue AI-List


    Die gesuchten .bus-Dateien findest du standardmäßig in: Omsi 2/vehicles/<Name des Busses>/


    In die Liste musst du dann einfügen: vehicles/<Name des Busses>/<.bus-Datei>


    Die Namen müssen so geschrieben werden, wie die Ordner bzw die .bus-Dateien benannt sind, am besten kopieren und einfügen (also den Namen, nicht die Datei

    ;)

    )

    Ein paar mehr Infos wären sicherlich nicht verkehrt: Logfile, auf welcher Karte passiert dies, welche Busse nutzt du, evtl. PC-Systemangaben, wann passieren die fehler (beim Laden der Map oder nach gewisser Zeit) etc.

    Es lag wohl nicht an den doppelten Zielen, ich habe es nochmal getestet.
    Konnte ja eigentlich auch nicht daran gelegen haben, da ja selbst in den Original-Spandau-Hoflisten das Ziel Betriebsfahrt sechs Mal enthalten ist.

    :whistling:



    OMSI hat wohl eher ein Problem mit fehlenden - oder vielmehr - leeren Einträgen in der Terminusliste. Diese habe ich nämlich auch gleich mal entfernt (hatte ich eigentlich eher wegen den nicht belegten Ident-Nummern als Platzhalter belassen).

    Hast du die bmp-Datei in den Ordner "Vehicles/Anzeigen/Krueger/" eingefügt? Ich gehe mal davon aus, dass die Hofdatei im Fahrzeug-Ordner enthalten ist und diese auch beim Bus-Spawnen ausgewählt wurde.

    Dass ein Tabulator am Anfang bzw zwischen den einzelnen Strings gesetzt werden muss, weiß ich und habe ich auch in der Hofdatei berücksichtigt und umgesetzt.
    Warum die Tabs hier aber nicht angezeigt werden, weiß ich auch nicht... obwohl diese im Antwort-Textfeld vorhanden waren.


    Mittlerweile habe ich wohl den Fehler herausgefunden:
    Es gibt/gab zweimal zwei gleiche Ziele in der addterminus_list -> "Flughafen Schoenefeld" bzw. "Bus endet hier"


    Diese beiden habe ich abgeändert (S Flughafen Schoenefeld wie es auch sein sollte) bzw. entfernt, damit keine doppelten Ziele mehr vorhanden sind


    Kaum starte ich OMSI und nun funtionieren die Zielanzeigen der KI-Busse und ich kann auch endlich die Routen im eigenen Bus einstellen

    ^^

    Ich arbeite gerade mit dem Editor an der originalen Map Spandau von M&R und versuche diese linienmäßig zu "modernisieren".
    Dafür nutze ich mittels der Chrono-Funktion auch eine "neue" Hofdatei.
    Leider möchte keiner der KI-Busse diese annehmen bzw. die Ziele in der Matrix anzeigen. Zwar kann ich diese Hofdatei beim Bus-Spawnen auswählen und den Bus damit spawnen, aber jegliche Routeneinstellung ist laut IBIS ungültig.


    Ein Blick in die Logfile zeigt mir folgende Fehler:


    252 21:53:19 - - Error: In "Vehicles\MAN_NL_NG\\Havelland 2016.hof" there was an error in line 66!
    253 21:53:19 - - Error: In "Vehicles\MAN_NL_NG\\Spandau 2016.hof" there was an error in line 48!





    Ich habe mir die vorhandenen .hof-Dateien "Spandau 94.hof" und "Havelland 1993.hof" kopiert und entsprechend Ziele und Haltestellen ergänzt bzw. die Routen neu erstellt.
    Im Editor habe ich bereits (nahezu) alle Trips erstellt und die Bus-Würfel bzw. Termini der Routen entsprechend der Hofdateien umgenannt.
    Die KI-Busse fahren auch alle (bisher erstellten) Umläufe, nur dass diese zwar Liniennummer anzeigen, aber keine Ziele, dementsprechend steigen auch keine Fahrgäste hinzu.


    Was mich am meisten wundert dabei: die laut Logfile angegeben Zeilen haben auch andere Hofdateien als Inhalt und diese funktionieren...


    Ich weiß nicht, woran dies liegt.

    ?(

    Es dürfte wohl an folgendem liegen:

    Benenne mal die Bezeichnung


    [aigroup]


    um in


    [aigroup_2]


    und füge wie bei der Aigroup "Normal Cars" noch die .bus-Dateien bzw .train-Dateien hinzu statt der Zahlen.



    Als Beispiel:


    [aigroup_2]
    OHE


    trains\ohe.zug
    [end]



    Das mit [aigroup] müsste noch das System der "alten" Ailist sein und daher hier stören.