Posts by chw94

The forum is in reduced operation. The Addon and Support forums remain open.
Please note that OMSI is no longer under development. Some of the developers are now working on a new simulator. Further information concerning the LOTUS-Simulator can be found here.
A community-lead successor to the OMSI forum will be linked here as soon as it is founded and ready.

    Zumindest zu diesen Fehlern

    Quote from Logfile

    241 19:41:16 - - Error: In "vehicles\DB_Doppelstockwagen\model\model_DABpz.cfg" there was an error in line 5!

    242 19:41:16 - - Error: In "vehicles\DB_Doppelstockwagen\model\model_DBpz.cfg" there was an error in line 5!

    243 19:41:16 - - Error: In "vehicles\DB_Doppelstockwagen\model\model_DBpbzf.cfg" there was an error in line 5!

    gibt's schon eine Lösung, siehe: Ruhrau 2.0 - Neuer Hotfix (10) - Stand 07.01.2019 - 20:30 Uhr


    Zu dem Festplattenschreibfehler kann ich leider nichts sagen...

    Bei Bügerhaus.sco und Alicenstraße.sco passt bei dir noch irgendwas nicht mit den Dateinamen der .sco-Dateien nicht. Hast du sie umbenannt? - Ich meine jetzt die Dateien selbst und nicht den Dateiinhalt. Die Pfade und Dateinamen im Addon-Manager und im Windows-Explorer müssen übereinstimmen, damit der Fehler weg ist.


    Bei Kisselberg3.sco und HDi.sco ist auch noch ein Fehler (hab ich vorher leider übersehen).

    Hier auch mal die Dateien öffnen und jpg auf bmp ändern, wie oben beschrieben.


    Folgendes hat nichts mit den Mainz-Objekten zu tun:


    Die Backgroundsounds (water cube und industry cube) scheinen dir auch noch zu fehlen. Die sollte bei Ruhrau V2 (?) dabei sein, glaube ich.


    Bei den letzten drei Zeilen fehlten Bilddatei in den jeweiligen texture-Ordner. Ist aber nicht so schlimm, da sind dann einfach ein paar Straßen/Splines weiß. Falls der Fehler von den Packs selbst kommt, dann musst du eine ähnlich ausschauende Bilddatei so benennen wie verlangt und in den jeweiligen Ordner einfügen um den Fehler zu beheben. Oft hat man die fehlende Datei in einem anderen Ordner und kann sie so herumkopieren dass der Fehler dann weg ist. Die Pfade müssen wieder übereinstimmen.


    Ich hoffe, das alles ist irgendwie verständlich formuliert.

    Neuer Versuch:

    Ich habe jetzt noch die Originaldateien mit meinen damals veränderten verglichen und nochmal die Originaldateien installiert. Da treten die Fehler wieder auf.


    (Achtung: vorher Backup machen!)


    Bei der Tuerme.sco ist auf jeden Fall ein Fehler:


    Bei Kisselberg1.sco, Kisselberg2.sco, Universitatis.sco, Mainz1.sco und Lerchenb1.sco:

    ist eine jpg-Datei eingetragen, jedoch nur eine bmp-Datei im texture-Ordner vorhanden.


    Bei Alicenstraße.sco und Bürgerhaus.sco ist so ein "Kodierungs-Problem" (Umlaute, ß, ...):


    Für die Bonifaziuskirche:

    So das sollte jetzt alles sein. Als ich damals die Fehler gefunden habe, war ich noch nicht so aktiv hier im Forum.

    Ich habe gerade die Mainz-Objekte nochmal neu heruntergeladen von der Webdisk, um es zu kontrollieren.

    Da sind die von HarryODL genannten Dateien jetzt aber doch vorhanden. Ich bin mir aber sicher, dass ich damals selber was korrigiert habe mit den Dateinamen/-typen. Komisch ...:/


    Sind die Mainz-Objekte bei Städtedreieck selbst dabei? Falls ja, vielleicht ist das eine veraltete/fehlerhafte Version? Oder der Download auf der Webdisk hat damals gesponnen, als ich den Fehler hatte?


    Vielleicht mal die Mainz-Objekte von der Webdisk neu herunterladen und überschreiben lassen (nur den 1. Teil der Mainz-Dateien und da den Ordner Sceneryobjects/Mainz).

    Bei den Mainz-Objekten gibt es, soweit ich weiß, ein paar Dateiformat-Fehler.

    In einigen *.sco-Dateien steht ein falsches Dateiformat bei den Texturen, zB *.jpg statt *.bmp (oder so ähnlich...) oder vielleicht auch falsche Dateinamen (Tippfehler). - Ist aber schon länger her, dass ich das bei mir behoben habe...


    Das müsstest du dann selber bei den einzelnen Dateien korrigieren/kontrollieren, ist halt etwas umständlich, aber du hast ja schon eine Liste mit betroffenen Dateien.


    Wenn du diese Fehler ignorierst, sind halt einige Häuser/Gebäude (zB in der Nähe vom Bf. Griesbach) weiß. Die Karte sollte trotzdem funktionieren, denke ich.

    Zum Problem

    Quote from Logfile

    122 21:23:20 - - Error: Sceneryobjects\YufaObjekte\Depot\model\pforte.o3d – o3d reading failed - Could not read the o3d file! Die angegebene Datei wurde nicht gefunden

    Diese Datei scheint dir zu fehlen bzw nicht an diesem Ort zu liegen.

    Mit den Yufa-Depot-Objekten gab es bei dieser Map schon mal Probleme, siehe hier: Städtedreieck V3.2


    Ansonsten das Depot-Set mal neu installieren und ggf. die Anweisungen in obigen Link beachten.

    Zumindest für diesen Fehler


    12:23:57 - - Warning: File Sceneryobjects\Objects_SN\Zaun_Tor_6m_02.sco: texture filename tex_a.bmp not found in mesh file Sceneryobjects\Objects_SN\model\Tor_6m_02.o3d!


    hätte ich eine Lösung. Siehe hier: Krummenaab 2019 --> Reissersdorf überarbeitet!


    Leider glaube ich aber nicht, dass das das Problem lösen wird, denn da scheint noch etwas anderes nicht zu funktionieren. Ich konnte aber auch nichts anderes im Logfile finden.

    Den Fix mit dem Doppelstockzug (siehe auf einer der vorigen Seiten) muss man auch wieder anwenden, falls man alles überschriebt, nur zur Info. (Da es Fremdcontent ist.)

    Lieber tempo1 !


    Ich habe nunmehr die Korrektur der Haltestellen bei mir durchgeführt, inklusive Drehen der Schilder und Neubeschriftung. (Hat doch nicht solange gedauert wie befürchtet, da ich die Tiles schnell feststellen konnte.)


    Wenn du möchtest, kann ich dir die korrigierten Tiles weitergeben, natürlich nur mit deiner ausdrücklichen Erlaubnis. Die neue Version der Brno-Objekte muss natürlich installiert sein und die alte deinstalliert.


    Ich denke, das würde dir unnötige Arbeit ersparen.

    tempo1,

    danke für die Rückmeldung! Der zusätzliche Aufwand wäre halt dann, dass man die Haltestellen drehen muss und die Beschriftung geändert werden muss. Die Font-Datei hat sich in der neuen Version geändert. Zum Glück ist der Tschechische Teil der Karte nicht so groß!


    Ich habe es versuchsweise mal bei Maria Loreto und beim Bahnhof Cheb problert.

    Z.b.: Maria Loreto -> einige Kleinbuchstaben sind jetzt Sonderzeichen (spezielle Ziffern für die Liniennummerntafeln, siehe Readme S.7 und S.10 der Objekte). Daher muss man alles auf Blockschrift ändern.

    Beim Bahnhof war früher das ß ein großes Z mit Hatschek, jetzt kann man einfach ein großes z mit Hatschek hinschreiben und es passt.


    @kl3206,

    sollte das nicht mit der heute veröffentlichten Version behoben worden sein? Vielleicht hast du sie noch nicht oder die Hof-Datei wurde bei einem deiner Busse nicht überschrieben (oder es wurde doch nicht behoben ... was ich aber nicht annehme)


    Edit: tempo1,

    in der holiday.txt scheint auch noch irgendwas nicht zu stimmen. 2021 sind ab April dauernd Osterferien, sogar bis Dezember (wäre in der Realität schön ;)) Da es wahrscheinlich eh keine speziellen Schul-/Ferienfahrpläne gibt, ist das aber nicht so schlimm, ansonsten ein anderes Jahr nehmen.


    Anbei noch ein Screenshot, wie die Haltestellen gefixt aussehen würden:

    Nein das nicht, man müsste nur alles richtig umbenennen und ändern (ein Tippfehler und es gibt fehlende Kacheln, da Omsi Objekte nicht findet)

    Natürlich kann sich die Änderungen jeder selbst auch machen, ist halt aufwendig. Keinesfalls erwarte ich, dass die Ersteller das erledigen. Hier ist ja alles auf freiwilliger Basis.

    Nach einigen Recherchen, habe ich zum Problem mit den Haltestellen (Brno-Objekte) in Cheb nun folgendens herausfinden können:


    Für diese Map wird im Download eine ältere Version der Schilder mitgeliefert, die scheinbar noch Fehler enthält bzw. nicht vollständig ist oder mit der neuen Version beim Installieren vermischt wurde.


    Die letztgültige Version ist hier zu beziehen: [Closed] Etrusan 3D . Laut dem beigefügten Readme soll man die alten Dateien vorher löschen.


    Leider hat sich in der neuen Version folgendes geändert (was das ganze nicht so einfach macht):

    1) Die gesamte Dateistruktur hat sich geändert (Dateinamen, Ordnerpfade, Namen der Objekte)

    2) Die Haltestellenschilder sind gegenüber der mitgelieferten Version um 90 Grad gedreht.

    3) Die Sonderzeichen der Fonts wurden auch verändert. (Dies führt dazu dass man die Texte der Schilder neu schreiben müsste.)


    Das heißt, wenn man den Fehler beheben wollen würde, müsste man entweder alle betroffenen Haltestellenschilder in Cheb neu erstellen, oder die Pfade in den Tiles ändern, die Haltestellen drehen und den Text ändern.

    Ist sicher ein Heidenaufwand, den ich von niemanden erwarten würde. Also werde ich vorerst es dabei belassen, die Map geht ja sonst.

    98Jan

    Danke für deine Bemühungen.

    Mittlerweile konnte ich das Problem auf folgenden Ordner eingrenzen:

    OMSI 2\Sceneryobjects\Brno\Zastavky (Dort sind die Haltestellenmasten aus Cheb)

    Da sind diverse Dateien im UCS-2-LE-BOM-Format (und auch anderen Formaten) Man müsste wahrscheinlich alle kontrollieren und ggf. den Inhalt abändern, dann die Umlaute und Sonderzeichen wieder ändern, das ist mir zu langwierig, auch mit einem Tool.

    Dafür habe ich dann die Anzeigen in Cheb. Nein, den Aufwand ist es mir nicht wert und die Map geht auch ohne dieses Beschriftungen und ist trotzdem wunderschön.


    Gaming Junge CZ : Soweit ich weiß, ist in den Doppelstockzügen leider auch ein Tippfehler, Link zur Behebung:

    siehe folgender Beitrag von fOcUs04: Ruhrau 2.0 - Neuer Hotfix (10) - Stand 07.01.2019 - 20:30 Uhr

    (Bitte logfile nächstes Mal verspoilern!)

    Danke für die Information, 98Jan!


    Ja, das ist mir gerade auch wieder eingefallen (Bei einer Repaint-Datei mit Umlauten hatte ich mal so ein Problem. Sie war vom Ersteller falsch abgespeichert worden). Ich bin auf diesem Gebiet nicht so bewandert.


    Wenn man die Datei findet, wo dieses "??????"! vorkommt, müsste man nur die Kodierung ändern und es würde wahrscheinlich wieder richtig funktionieren. Die Frage ist nur welche Datei es ist, da im Logfile kein Pfad angegeben ist. Falls ich mal sehr viel Zeit habe, werde ich es mir nochmal anschauen.

    Hallo, ich bin's nochmal.

    Diesmal etwas eher Kurioses:

    In folgender Datei ist noch ein Tippfehler:


    OMSI 2\Sceneryobjects\Objects_RS\Zaun_6m_02.sco (Ich weiß jetzt nicht, ob Eigen- oder Fremdcontent)


    Es wird nicht angezeigt, wenn ich den Text hier einfüge, daher als Screenshot:


    Zwischen dem x und dem Unterstrich ist dieses komische Sonderzeichen, es wird aber nur in Notepad++ angezeigt und jedoch nicht im normalen Windows-Editor, daher wird es niemand so einfach finden ...

    Zumindest im Logfile hatte ich diese Fehler-Meldung schon mal, dass die Textur nicht gefunden werden kann, auch dort scheint dieses "US"-Zeichen (Was ist das eigentlich???) nicht in der Fehlermeldung auf, wenn das Logfile mit dem Windows-Editor geöffnet wird.

    Das Neu-Hinschreiben hat das Problem jedenfalls gelöst.



    Mit den Haltestellenbeschriftungen in Cheb/Eger habe ich auch noch Probleme - Fehlende Beschriftung, obwohl in den Objekt-Strings (siehe Map-Editor) etwas eingetragen ist. Das stört mich aber nicht wirklich, also werde ich es nicht weiter verfolgen. Außerdem sind die betroffenen Dateien auf Tschechisch (und das ist mir dann zu umständlich...) War da nicht mal was, dass Leute die keine Deutsche Sprache eingestellt haben, Probleme mit Omsi (Umlaute, scharfes ß, etc.) haben. Vielleicht ist es hier mit dem Tschechischen ähnlich.


    Es hängt möglicherweise mit folgenden Fehlermeldungen im Logfile zusammen (Vermutung):

    Warning: Did not find texture file "??????"!

    Warning: Did not find texture file "text.bmp"!


    Zumal diese beiden Fehler nur auftreten, wenn ich die Karte in Eger starte.

    Falls das nicht gelöst werden kann, ist es nicht so wichtig, da es das Spielerlebnis für mich nicht beeinträchtigt.

    In der hof-Datei gibt es noch folgenden Fehler:

    Code
    1. [infosystem_trip]
    2. 4202
    3. C42 Tierheim - Stadtgarten
    4. 100 <--- hier gehört stattdessen 103 hin, da das Ziel 100 für die Linie C41 ist.
    5. 42

    Die Ansage-Datei "Flossenbürg, Sankt Mariahilf.wav" gehört umbenannt in "Flossenbürg, St. Mariahilf.wav" damit sie richtig abgespielt wird.