[OMSI2] Error messages in normal using or after addon-installations

  • Contents:
    .Page:...Posting:...Topic:
    ..01......No. 01....Contents
    ..01......No. 02....Solve o3d-error
    ..01......No. 03....Fix the "E/A-Fehler 123"
    ..01......No. 04....OMSI laggs when loading a map
    ..01......No. 05....Invalid Track Entry
    ..01......No. 06...."Ungültiger Dateiname"
    ..01......No. 07....New map isn't showed in OMSI-Menu
    ..01......No. 08...."Zugriffsverletzung" and/or o3d-error message when loading addon maps (according
    to ADDON_gcW)
    ..01......No. 09...."Zugriffsverletzung"s and dumb passengers
    ..01......No. 10....IBIS is remainig blank
    ..01......No. 11....Fix a "Zugriffsverletzung"
    ..01......No. 12...."Kreuz_zepp_pirmasenser.sco" is missing
    ..01......No. 13....Logfile Warnings
    ..01......No. 14....Missing objects although correct installation
    ..01......No. 15...."Zugriffsverletzung"s and errors associated with "SoundSort Fail"


    Translations by pBuch

  • I always get an o3d-error when loading a map!


    "Could not read the o3d-File!" - This error message is probably as popular as the error "Ungültiger Dateiname"(scroll further down for solution). It's caused by third party addons. If a reinstallation of the faulty addon doesn't work, a manual search in your sceneryobjects-folder would be recommended. If you don't know how to do that, you can either contact the author of the addon or look into your logfile.
    But a o3d-error isn't a catastrophe because there won't be a "Zugriffsverletzung" after this error-message. So it doesn't have to be fixed.

  • Everytime I want to use the OMSI-Options I get an "E/A-Fehler 123".


    In many cases, this error is caused by russian vehicles. These include cyrillic letters in it's files and the "german" OMSI doesn't know how to use them. Some busses known as faulty are the LAZ699 or the Temsa Safir (which isn't downloadable yet). If you use any of the "E/A-Fehler"-busses you will have to remove them from the OMSI-folder in order to use the OMSI-options. Or just delete them anyway. For the MAZ103-addon which causes this error also, there's a solution found. Just rename all foldernames and *.bus-files with latin ("normal") letters and delete all files from the script-folder which have cyrillic letters in their name. If you get this message when saving a map in OMSI-Editor, look if there are files opened with windows texteditor or if you have opened the OMSI-Editor twice. Then OMSI cannot overwrite the
    file and that will cause an "E/A-Fehler 123".


    P.S.: "E/A-Fehler" stands for german "Ein- und Ausgabefehler" which means "input-output error"

  • OMSI is lagging when loading "Kacheldateien"(tile-files) with every map except Grundorf.


    When loading the title-files, you have to be a bit patient, especially if you have got an elder PC. Grundorf is a tiny map, but loading the titles of maps such as Römerberg, Spandau, Rheinhausen, etc may take some time. The best would be to close all background processes to provide OMSI as much PC-power as possible. Don't minimize OMSI or start other programs while loading a map because then the loading will stop!

  • I get an error message "There is an invalid Track Entry".


    There are several possibilities:


    OMSI tries to load a piece of street but it cannot find the Spline in the OMSI-Installation. Be sure that you have all necessary addons of the map installed. OMSI will also make an error message such as "Spline not found". If there's no such error message you have to open the map in OMSI-Editor and click in "Tracks&Trips" menu on "Find Errors!". OMSI will guide you to the faulty paths. Maybe there's space between two paths or one path is selected twice. Fix that and click on "Find Errors!" again. Just fix all errors until you get the message "No Errors!" after pushing that button. The problem should be solved then. If you get the Invalid Track Entry after updating a map remove the whole map-folder of the addon (e.g. \OMSI\maps\Bad Kinzau\) and reinstall the map again. The error is caused by old unused files from the old version of the addon which have to be deleted.


    The error message can also come up when you load an old map. Maybe some sceneryobjects like crossings have been updated and changed their paths. Then you should contact the objects' or the map's author.

  • This error translates into "Invalid Filename".


    Sometimes, this error can be very annoying. It can cause "Zugriffsverletzung"s and let the OMSI- Editor show not all objects.


    To fix that error, you have to find out which object is causing the error firstly. Put every folder from the Sceneryobjects folder out of OMSI and push the button "Load all!" in OMSI-Editor -> Menu "Objects". If the message isn't comming up again, you know where the faulty file is located. If the faulty folder is part of an addon, the best solution is reinstalling the addon. If the error comes up again after reinstalling, contacting the addons author would be recommended. If the faulty folder is part of the OMSI original files (MC, RUE in foldername) you have to repair OMSI. If the error message is coming up directly when starting OMSI you also must repair OMSI in order to fix that error.

  • I get a "Zugriffsverletzung" or a o3d-error message ("o3d could not be loaded!) when loading a addon-map! What can I do?


    Firstly, take a look in OMSI-logfile (it's the file "logfile.txt" in your OMSI-main folder) with Windows Editor. Many addons need the objects-pack "gcW Straßenobjekte" from "seeadler". Because he has used filenames with umlauts, it comes to problems with foreign hosters or pc-systems. If your logfile contains the following code:

    Error: The object "Sceneryobjects\ADDON_gcW\ampel_rot_gr[random letter]n.sco" could not be loaded!

    (You must replace [random letter] with the letter, that's shown in your logfile (e.g. "ü", "Б" or "ь")


    Open the folder ...\OMSI\Sceneryobjects\ADDON_gcW\ and search for a file called "ampel_rot_grn.sco", "ampel_rot_grün.sco"or something like that. Now take a copy of that file and rename it to the name that was shown in your logfile. Now the object is accessable for OMSI again and the error is fixed.

  • I always get "Zugriffverletzung"s and passengers don't say anything and don't buy tickets.


    Open the global.cfg (...\OMSI\maps\[Mapname]\global.cfg) with Windows Editor and check if the path to the ticketpack (after [ticketpack]) is valid (there's a file with that path) and the file extension is *.otp. Be sure you installed the Ticketpack of the map (if existing) correctly.


    If the passengers are only sometimes dumb and there's no "Zugriffsverletzung", increase "Max. Soundcout" in OMSI-Options -> Sound.

  • Because a "Zugriffsverletzung" can have many reasons, there's no general answer. In order to fix a "Zugriffsverletzung", it mostly helps to search for threads where other users have the same problem (important: where, when, how the error message is coming up). If that doesn't help, you can start a thread in the support-forum or just contact an expert.


    Please remember to name:

    • How the "Zugriffsverletzung" comes up (once, multiple times, ...).
    • When the "Zugriffsverletzung" comes up (When loading a map (e.g. "Loading Objects"), while driving, with a special bus, ...)
    • Which addons have been installed most recently? Have you installed all required addons for this addon?
    • Does the "Zugriffsverletzung" only come up on a specific map or on every map?
    • Where do you think is the error?
    • Also post the logfile (logfile.txt in you OMSI-Mainfolder) and the ai-list (...\OMSI\maps\[specific mapname]\ailists.cfg)


    Then you are well on the way for help

  • To fix this error just update to OMSI version 1.01 because this crossing is only included in version 1.01. You can download the update on the website http://www.omnibussimulator.de.


    Please also remember that version 1.01 isn't the last version anymore. You can download the new patch in your Aerosoft-Supportcenter or here, but you need 1.01 in order to install it.

  • Warning: Did not find texture file "30er_reihensiedlung01.bmp"!
    Warning: Did not find texture file "SD_Rad_v.bmp"!
    Warning: Did not find texture file "reifen.bmp"!
    Warning: Did not find texture file "path_car_1.bmp"!


    Why do I get this warnings?


    Take it easy! This warnings are standard. Everyone gets them. But they won't disturb you while playing.

  • Maybe, there have been objects added in a new version to the object pack which have been added to the map. So be sure you installed the last version of the objectpacks.


    Sometimes the author of maps use other folders as the users. To fix this problem there are two options:

    • Open the map in OMSI-Editor. Now you can replace every missing object with the right one. Then save the map.
    • Copy all missing object from the directory you installed them and place them where the map is searching for them (you will get the path from the error message).
  • I always get a "Zugriffsverletzung" when loading a map or driving around. Then I see the following error in my logfile:
    Error: SoundSort Fail: Invalid distance calculation![...]


    The solution is simple:
    Go into OMSI-Options -> Sound and put "Max. Sound-Cout" to the right (approximatelly 900-1000). Click on "OK". Now the problem should be solved.