Omsi SDK Kreuzungs Editor Fehler

The forum is in reduced operation. The Addon and Support forums remain open.
Please note that OMSI is no longer under development. Some of the developers are now working on a new simulator. Further information concerning the LOTUS-Simulator can be found here.
  • Hallo

    Ich wollte heute ein Objekt (Ampelschaltung) etwas anpassen aber ich habe das Problem das sobald ich eine Datei unter Objekt Load (STRG+L) laden will kommt die Fehlermeldung


    Omsi liegt unter dem Dateipfad

    C:\Program Files (x86)\Steam\steamapps\common\OMSI 2\SDK\RepaintTool


    Und es liegen soweit ich weiß alle nötigen Dateien im Ordner

    (Auch neu Installation hat nichts gebracht)

    Mfg

    Tjum28

  • Hallo

    Ich habe es jetzt geschafft eine Ampelschaltung zu erstellen habe das erstmal an den Splines von Kartoffelphantom versucht.

    Da habe ich dann beim Objekt spawnen eine Fehlermeldung bekommen Zugriffsverletzung.

    Dann habe ich das mit den von EVAG gemacht da habe ich aber auch das Problem das sobald ich das Objekt spawnen will das ich eine Zugriffsverletzung bekomme und alle Objekte verschwinden.

    Kann mir jemand helfen?

    Mfg

    Tjum28


    Beiträge zusammengeführt. Ein neuer Thread ist nicht vonnöten. :-) In Zukunft bitte den vorherigen Beitrag editieren und nicht die Doppelpostsperre versuchen zu umgehen. Danke :-) //Semedah

  • Ne. Das Objekt ist ja nur das wo die Pfade "drauf" sind. Aber die Pfade müssten als einzelne Pfade in deiner sco eingetragen werden, wenn du diese im kreuzungseditor erstellst.


    Wie sieht denn dort deine Kreuzung aus? Wie viele Pfade hat diese dort. Und sonst zeig doch mal ein Bild davon :)

    Wir sind umgezogen: https://reboot.omsi-webdisk.de/

  • Das mit den Pfaden ist schon alles okay, das sollte hier den Fehler nicht verursachen. Ich habe mir die .sco mal ganz genau angeguckt und nachgerechnet, und dabei ist mir aufgefallen, dass einige Ampelphasen zu lang zu sein scheinen, sodass einige Phasen sogar schon komplett "hinten rausrutschen". Sind Ampelphasen zu kurz, ist das für Omsi kein Problem, da wird einfach die letzte bis zum Schluss gestreckt. Bei deinen Phasen "Tram mit Punkt Seite" und "People main" Sind die eingestellten Phasenzeiten schon länger als deine gesamte Umlaufzeit von 39 Sekunden, und du hast jeweils am Ende noch mal eine einsekündige Rotphase, die in beiden Fällen erst nach den 39 Sekunden beginnt, also im regulären Ampelturnus eigentlich nie zu sehen sein dürfte. Möglich wärs, das Omsi sowas nicht mag, und sich daran verschluckt.


    Die beiden Rotphasen würde ich also empfehlen zu löschen, und bei den "People main" könntest du die Grünphase am Schluss vielleicht auch noch etwas einkürzen, irgendetwas unter 13 Sekunden sollte passen. Dazu eventuell mal die Gesamtumlaufzeit etwas erhöhen, dann sollten die beiden Rotphasen sichtbar werden, und du kannst sie besser entfernen.